Jump to content
scaba

Catalina app symlinks

Recommended Posts

I use emacs-plus from Homebrew. `brew link emacs-plus` creates a symlink in /Applications to the Emacs.app dir that lives in the Homebrew dir. Since upgrading to Catalina I can no longer see Emacs in the Alfred search bar. If I add the /usr/local/opt/emacs-plus dir to Alfred - which is itself a symlink - it resolves to the actual dir as illustrated below, but Emacs still does not show up as an option when I search. Adding /usr/local/opt to the Applications list in Alfred also has no effect.

 

/Applications/Emacs.app -> /usr/local/opt/emacs-plus/Emacs.app

/usr/local/opt/emacs-plus -> ../Cellar/emacs-plus/HEAD-3a95ce1

 

macOS: Catalina 10.15 Beta (19A471t)

Share this post


Link to post
Share on other sites
Posted (edited)

@Andrew I had not, so I just tried. I dragged the Emacs.app symlink into that box, but it still doesn't show up in Alfred. I also cleared the app cache to make sure. This was working in Mojave so I'm thinking something in Catalina changed that causes Alfred to no longer follow the symlink or even recognize them as such. And since .app files are directories, you can't make hardlinks to them, which could possibly have been a workaround. However, running `open -a Emacs.app` does work, so for now I just do that. Plus, how often do you need to restart Emacs anyway :)

Edited by scaba

Share this post


Link to post
Share on other sites

×
×
  • Create New...