Jump to content

Can't Assign New Hotkey

Recommended Posts

I'm trying to create a simple workflow to open a folder with a hotkey. I've done other hotkey workflows int he past with no problem. When I click in the box to enter the key macro (it's got the blue box around it so I know it's selected), it just does nothing when I enter any keystrokes. I went to one of my existing hotkey workflows and was able to modify the key macro, so it seems to only be impacting net new workflows. Anyone seen this before?


Alfred 4.0.1 b1078

macOS Mojave 10.14.5

Link to post
11 hours ago, skarchmit said:

Could the keystroke be possibly assigned to another action already? Say an app is using it or maybe the system?

I used to have spectacle do the same issue. 


I don't think that's the case as I've assigned hotkeys that override system and app hotkeys a number of times with no issue. Alfred hotkeys take precedence over system/app ones. Unless that's changed w/ v4, but I don't think so?


Link to post
3 hours ago, stylophile said:

Alfred hotkeys take precedence over system/app ones. Unless that's changed w/ v4, but I don't think so?


I don't think it's so much a question of precedence as of restrictions that Alfred actively places on which Hotkeys you can set. I don't specifically know if these have changed in Alfred 4, but @Andrew certainly did make some changes to Hotkeys to improve their behaviour when keyboard mappings change.


He's the best person to spell out what you can and can't do.

Link to post
1 hour ago, Andrew said:

Basic question - have you tried setting an obscure combo which isn't used by any other apps, just to make sure?


I tried several at first to see if it that was it, but no change, however just now I tried adding another modifier (Ctrl-Opt-Cmd-H) and that worked. So I'm guessing in Alfred 4 something changed to check other macros and help prevent you from stomping on them. If that's the case, I'd like to request a feature to toggle that as an option; I have no idea what Ctrl-Cmd-D is mapped to (I tried using it and also searched through Keyboard Shortcuts control panel) so I'd prefer to override it with an Alfred hotkey. 

Link to post

@stylophile Alfred 4 hasn't changed in this regard compared to Alfred 3 and before... if another app is already using a specified combination, macOS will divert this combo to that app and Alfred (and Alfred's Preferences) won't even know this combo has been pressed (i.e. for you to set a hotkey in one of Alfred's hotkey fields). It actually acts as an inherent safety net to prevent a key combo from being registered twice, and causing undesirable behaviour.


Having said that, not many apps will be registering system level hotkeys, so you may have an (accessibility based) app which is interfering with the combos before they are even distributed by macOS. Check the macOS Accessibility preferences to see which apps have access here. Also, perhaps try a new user account with Alfred to see if you are able to register more combos there?




Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...