Jump to content
seanwes

Typing Lag on Alfred 4

Recommended Posts

I'm currently on Alfred 4.0.2 [1088] (though this was also the case on Alfred 3).

 

I get about half a second of lag when typing. Only the first letter of my query shows, and then a moment later the rest of what I typed appears.

 

I read all of the posts about disabling blur. When I was on Alfred 3, I did that to no avail. I gave up on the issue when I saw that Alfred 4 was coming out, figuring it would probably be fixed.

 

ow, I'm on Alfred 4, and the typing lag issue persists. Also, I do not see the same blur option to even try to see if disabling works.

 

Any advice?

Share this post


Link to post

@seanwes lag like this is unusual, and most the time, it can be attributed to the macOS indexing / query setup. First thing to try would be to rebuild your Mac's metadata index using the shortcut in Alfred's Advanced preferences.

 

If that doesn't work, let me know :)

 

Cheers,

Andrew

Share this post


Link to post

Thanks for the reply, Andrew. Unfortunately, the issue persists after following your suggestion. What is the next step?

 

What I've included below is just for anyone else in the future who finds this post from a search.

 

___

 

I had trouble rebuilding the index initially—I got this message in Terminal when I first attempted:

rm: /.Spotlight-V100: Operation not permitted

I discovered it's because macOS Mojave is quite strict about which apps have Full Disk Access.

 

After I did the following, I was able to rebuild the index:

 

System Preferences > Security & Privacy > Privacy (Tab) > Full Disk Access > (Click "+" and add Terminal).

 

So the good news is, I was able to rebuild the index after doing this. The bad news is, doing so did not solve my typing lag issue.

Share this post


Link to post

@seanwes the next thing would be to temporarily reset Alfred's preferences to see if it's a misconfiguration or corruption.

 

Quit Alfred then open Finder to ~/Library/Application Support/Alfred/. Move Alfred.alfredpreferences and prefs.json temporarily to another folder (e.g. your desktop) and then restart Alfred.

 

Is the lag still there?

 

Cheers,

Andrew

Share this post


Link to post
On 6/25/2019 at 3:28 PM, Andrew said:

@seanwes the next thing would be to temporarily reset Alfred's preferences to see if it's a misconfiguration or corruption.

 

Quit Alfred then open Finder to ~/Library/Application Support/Alfred/. Move Alfred.alfredpreferences and prefs.json temporarily to another folder (e.g. your desktop) and then restart Alfred.

 

Is the lag still there?

 

Cheers,

Andrew

 

^^^^ This solved my lag issues!  Thanks!

Share this post


Link to post

Hi, I have same problem.(Lag whem typing)

 

The solution above doesn't work for me.

 

Is there any other solution? 

 

Alfred4.0.9 / macOS10.15.4(19E287)

 

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...