Jump to content
theboyler

Applescript in Alfred 4 problems

Recommended Posts

I had a workflow in Alfred 3 that opened the color picker; it worked in Alfred 3 but not in Alfred 4. 

 

It was a simple keyword 'col' to an applescript with this code

 

on alfred_script(q)
	choose color
end alfred_script

Now, when I run it, nothing happens. I debug the script, and I get:

 

[13:37:26.910] Color Picker[Keyword] Processing complete

[13:37:26.913] Color Picker[Keyword] Passing output '' to Run NSAppleScript

 

Is there some additional setting I need to use? 

Share this post


Link to post

Unless you know what you’re doing and that you need to use Run NSAppleScript, don’t. Use a Run Script with /usr/bin/osascript instead (the Run NSAppleScript points that out).

 

You’ll only need choose color as the full code. Does that work? If not, please post the full Workflow (i.e. upload it somewhere), so we can take a look. Also, what macOS and Alfred versions are you on?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...