Jump to content

[SOLVED] Can Alfred index files & folders in mounted volumes?


Recommended Posts

I'd like to search via Alfred for files and folders in my mounted volumes which are usually mounted 24/7.

 

I explicitly added the path of a volume like "/Volumes/..." to Alfred Preferences > Features > Default Results > Search Scope (and "Extras" > Folders is enabled). 

 

When I search for known folders or files I do not get any results from this volume. How is this possible?

 

I am using Alfred 4.0.2 (but had the same behavior with any version of Alfred 3, though I finally reach out). 

 

Thank you. 

 

 

Link to post
  • vitor changed the title to [SOLVED] Can Alfred index files & folders in mounted volumes?
  • 3 months later...

I have the same issue, but the mdutil command did not help. The volume shows that it is being indexed. Even weirder, spotlight *used* to show these results, but it just stopped showing results on the mounted drives. I've tried "reload", and I've confirmed that spotlight can find the items. Any ideas? Thanks

Link to post
  • 7 months later...

It works for me without issues with Alfred 1.2 (the one on the App Store).

Added the volumes on Alfred 1.2 and it asked for mounted drives access permissions, then all good.

 

On Alfred 4, even when adding them on Alfred's preferences and Spotlight private section (added the same folders) it didn't work.

 

For now I'll use it as is, it's ultra fast and finds everything, but too bad that I'm missing on potentially amazing features since many years it has been going forward.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...