Jump to content

Exclude files in Alfred but not in Spotlight


Recommended Posts

12 minutes ago, dfay said:

tag them alfred:ignore 

 

That's likely not going to work super well, as it requires tagging every single file :( 

 

2 hours ago, Hans Tammen said:

I like to find my DevonThink databases, but not the individual files within them. What did I overlook?

 

The best solution is probably to set up a File Filter that only considers the DevonThink database filetype (if that's possible).

 

Alfred's search model is include-only: there is no blacklist/exclude option. So you have to approach it from a "how do I include only types X and Y" perspective, not a "how do I ignore type Z" one.

Link to post
1 hour ago, dvcrn said:

Is that an actual tag now? I read about putting it in the Comments field at other places

 

It can be either.

 

1 hour ago, dvcrn said:

Also is this usable for folders or just for single files?

 

Depends what you mean. If you add the tag/comment to a folder, that folder will not appear in Alfred. It has no effect on the contents of the folder, however.

Link to post
  • 1 month later...

@the_archpadre There are a few options here:

 

  1. You can simply select iTerm a couple of times, and Alfred will learn from your usage, bringing iTerm to the top :)
  2. Assuming you're using Alfred 4, under Features > Default Results, click the Applications: "Options" button at the top, and uncheck "Match Application's keywords in default results". Podcasts matches "it" because "iTunes" will be in the app's additional keywords pre-set by Apple
  3. Otherwise, here's how you can tag System apps: https://www.alfredapp.com/help/features/file-search/tagging-files/#spotlight

Make sure you type "reload" into Alfred after tagging to blacklist it.

 

Cheers,
Vero

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...