Jump to content
chriscalo

Recognize 3,360/2 as math

Recommended Posts

I often copy numbers and paste them into Alfred to do quick math on them like dividing by 2. Numbers are often formatted with commas, and this causes Alfred to not understand them as numbers. Then I have to manually remove the comma, while this seems like some that should just work. It would be great if Alfred could recognize expressions like the following as math:

 

3,360/2

 

66499187-504ca780-ea8d-11e9-9fe1-fcab195

Share this post


Link to post
Share on other sites

Oh, my goodness, thank you so much for pointing that out 🙏

 

(can I change my feature request to just making this setting the default? why would you ever not want this?) 

Share this post


Link to post
Share on other sites
26 minutes ago, chriscalo said:

just making this setting the default?

 

AFAIK, the default is to use whatever you've set in System Preferences.

Share this post


Link to post
Share on other sites
46 minutes ago, chriscalo said:

Not sure what System Preferences you're referring to.

 

System Preferences, not Alfred Preferences.

image.png.c754fd4ae6a649bc85f53e7b14ec0f24.png

If you don't know "System Preferences", then you presumably don't have your macOS set to English, so your thousands delimiter isn't set to comma.

image.thumb.png.358681f4dc0e07c928edd9767ca1767c.png

image.thumb.png.583fdcf9f8f1dc45ecdbb5dbcb2ae156.png

Share this post


Link to post
Share on other sites

I'm aware of what System Preferences is. My point was that you didn’t mention which preference you were referring to your reply. Thanks for clarifying.

 

It turns out the preference you mentioned is not the source of the issue. Mine is set exactly as in your screenshot.

 

When Alfred's "Ignore thousands grouping separator" is unchecked, Alfred fails to correctly interpret 1,234 * 2.

When it is checked, everything works as expected.

 

Thus, my feature request is to default Ignore thousands grouping separator to on for all users.

 

I now know how to fix this for myself, so my issue is solved. I'm humbly suggesting that checking the Ignore thousands grouping separator box by default would be a usability improvement for all other users trying to paste numbers into Alfred to do math on them.

 

Cheers,

Chris

Share this post


Link to post
Share on other sites
On 10/11/2019 at 5:14 PM, chriscalo said:

My point was that you didn’t mention which preference you were referring to your reply.

 

Right, sorry. I got confused and was holding tightly onto the wrong end of the stick there…

Share this post


Link to post
Share on other sites
On 10/9/2019 at 10:02 PM, chriscalo said:

can I change my feature request to just making this setting the default?

 

This isn't enabled by default as it adds confusion between whether comma or dot is being used as the decimal separator under certain circumstances.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...