Jump to content
Sign in to follow this  

Catalina: HotKeys not functioning

Recommended Posts

Posted (edited)

I upgraded to Catalina last night and my hotkeys are no longer functioning.  I've read a few different threads on the topic but haven't been able to find a resolution.  I've checked the permissions for Alfred (full disk access, accessibility, automation).  Alfred is not listed under automation and I see no way to add it or trigger Alfred to ask for this permission.  If I boot up under Mojave everything is working fine.  I've tried deleting my Application Support folder as well as Alfred Preferences to no avail.   I've tried watching Console messages but don't see anything directly related to Alfred.  These messages tend to pop up when I press my hotkey but I can't say that they're related to Alfred

error   15:20:22.832441-0400    WindowServer    Sender is prohibited from synthesizing events

Anything else I should try?

Edited by AndrewS

Share this post

Link to post

Are your hot keys opening apps?  I too thought my hotkeys had stopped functioning when I upgraded to Catalina (which is what brought me to this page).  Eventually I realized that the hotkey tigger was fine.  It was Alfred calling the app that needed to be changed.  Apparently /Applications/Mail.app is now /System/Applications/Mail.app — at least that's what Alfred sees — and what was formerly /Applications/Microsoft Word.app is now /System/Volumes/Data/Applications/Microsoft Word.app.  All this apparently has to be manually changed in Alfred, workflow by workflow.  


(If this is not your problem, my apologies for intruding.) 

Edited by dpdpdp

Share this post

Link to post

Thanks for the suggestion as it was indirectly helpful.  So.... the hotkeys are working, it's the clipboard auto-paste functionality that's not working (and what I was trying to trigger on a hotkey).  Which seems to be a problem with the clipboard functionality overall.  The clipboard advanced option "Auto-paste on return" isn't working. 




Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  
  • Create New...