Jump to content

Open from Recent Documents of an app is not working in Catalina


pzgz
 Share

Recommended Posts

Catalina is official released now, guess we should put bugs here.

 

With catalina and latest alfred installed, recent documents of an app is not working, searched for an app, and then select reccent documents, pick an file but no window openned. 

 

If I launch alfred again and open that app, I will see previous selected file was openned. Or if the app is running before I tried to open a file from recent documents, it will be opened.

 

I got following error from console:

 

Oct 14 13:22:23 Leons-iMac com.apple.xpc.launchd[1] (com.apple.xpc.launchd.oneshot.0x10000016.OmniOutliner[15083]): Service exited due to SIGKILL | sent by Alfred[526]
 

Link to comment
Share on other sites

@pzgz Could you please specify:

  • Which version of Alfred and Catalina are you using specifically?
  • Which apps aren't returning recent documents?
  • Did you grant Alfred Full Disk Access in the accessibility preferences?

The Recent Documents feature works well in our testing for native macOS apps; Certain non-native apps like Microsoft Word have never returned recent documents, as they're stored in an illegible format that Alfred can't use.

 

Cheers,
Vero

Link to comment
Share on other sites

  • 5 months later...

@Luis Martins I've just tested in macOS 10.15.4 and Alfred 4.0.9 with Apple's TextEdit.app and am seeing recent documents, so this should still be working as expected.

 

Does it work for any apps, such as TextEdit? or does it not work at all?

Which versions of Alfred and macOS are you using?

 

Cheers,

Andrew

Link to comment
Share on other sites

  • 2 weeks later...

I finally upgraded to Catalina and am having the same problem. If I search for an app and arrow right to Recent Files there is nothing there, even though Spotlight (and the app itself) are aware of recent files. I have all of the accessibility options turned on. Where else should I look?

Link to comment
Share on other sites

@HeatherH I've just done a couple of simple tests with Preview.app in Catalina by opening a couple of images outside of Alfred. It can take a short delay (in my case a 5 seconds) before Preview updates its recent entries file, but then Alfred sees them fine.

 

Is there a specific app you're trying recent documents with? Have you tried with Preview.app?

 

Perhaps try removing Full Disk Access and re-granting it to Alfred?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...