Jump to content
dansmans

Only Apple's Own App's Found - Spotlight Issue?

Recommended Posts

Hello,

 

Both Alfred and Spotlight no longer show any other app than Apple's own.

 

I have tried to re-index (via MacPilot, via Terminal, via Privacy pref's), clear Alfred's cache, tried the rebuild MacOS metadata, used the 'reload' command, ticked the box for MacOS application folder, added custom paths (applications, utilities), did a permission check, verified with Disk Utility. All to no avail.

 

My system runs on Catalina v10.15 and Alfred is on v4.0.5. At first, right after the upgrade to the latest versions, Alfred and Spotlight ran as expected. However, Spotlight did no longer provide any results within Outlook. I am now in an escalated support cycle with Microsoft, which has me rebuilding profiles, re-indexing Spotlight and verifying permissions etc. Since the last re-index/rebuild session, both Spotlight and Alfred no longer show any app's other than Apple's own.

 

FYI: Spotlight also no longer gives me any search results other than its own database/index information (Dictionary, Reminders, Calendar, Notes, Messages). I used to see OLK15Messages (the Outlook mail message type), now I only get Apple Mail results.

 

Is this a known issue, something logically related to a known issue, or am I just looking at a unique situation?

 

It seems to me that Apple has increased restrictions (just like it is no longer possible to have 3rd party app's access mail, calendar and reminders items) and locked up locations.

 

Can you help me out?

 

Thanks.

 

Dansmans.

Share this post


Link to post

@dansmans Search should work smoothly in Catalina, and both Spotlight and Alfred should be returning search results. Alfred relies on the underlying macOS index maintained by Spotlight, so once you get your Spotlight index working, Alfred should also return results.

 

It sounds like you've tried quite a variety of things already, and we also generally recommend rebuilding your Mac's index when no results are returned, but here's our indexing troubleshooting guide in case it provides further insight:

https://www.alfredapp.com/help/troubleshooting/indexing/

 

Beyond this, you may have a botched Catalina upgrade, and while we can't recommend that you reinstall, you may choose that it's the best step forward.

 

Cheers,
Vero

 

 

Share this post


Link to post

Hi @Vero,

 

Thanks for the quick response. I appreciate it.

 

The reinstall route did cross my mind, but I rather try to fix it and understand why and how. No masochism, just curiosity... 😉

 

For now, I think it is related to a Spotlight/Permission issue and/or a corrupt index. I assume there is a combo of pref's in different places that, together, throw off the index process. I just don't know where to look.

 

Maybe for others that bump into a similar problem: I found out this morning (after the Catalina Fix/Update), that the App Store shows my purchased apps, but is indicating that these are not installed. Upon clicking the install button (cloud icon in App Store), it says to rename/remove the installed app, after which it re-installs the app in the same location. I used the Alfred Metadata Tool to quickly look at the info (BTW: great quick help!): Apple's own apps show much more information than the others.

 

 

CleanShot 2019-10-17 at 12.09.54@2x.jpg

CleanShot 2019-10-17 at 12.10.32@2x.jpg

Share this post


Link to post
3 hours ago, Andrew said:

@dansmans The output from Acorn.app shows that it's not being indexed by macOS.

 

Hi @Andrew,

 

Thanks. That's what I thought too. But I am trying to find out why this is and how I can fix that. What could be the reason that the index is not being populated with the correct data? Could it be that the package receipt and/or plist/pref is not stored correctly? The app is in place, accessible and runs without any problem. The package content is clean, the pref's are in the correct place and all seems OK. So it seems that there might be a location that stores something else or something in addition. It seems as if the required data for indexing got lost along the way. Quite possibly as a side-effect of the Catalina upgrade.

 

Do you know if it's possible to open the Spotlight index as an ordinary database view when mdworker is 'frozen', so an end-user like myself can add/review? In this case, to see if I could inject Acorn data, as if it has been indexed.

 

Dansmans.

Share this post


Link to post

Hello @hzlzh,

 

After a long, but very pleasant, support call with Apple, we came to the conclusion that it is not Catalina, nor Spotlight itself that has an issue. Rebuilding, re-indexing, cleaning: whatever I did was not making any difference. I created an admin and standard user to double-check and see if it would be a user profile issue, or a system-wide issue. We sifted through the logs and checked all apps on my system. Since I used all tricks in the book, using all different tools I could think of, there was nothing else to look for: it is an app that interferes or prevents Spotlight to get access to the information.

 

Long story short: in the end I uninstalled every app that could have an influence, notably 3rd party security-type apps, such as firewall, backup, anti-virus/malware. But also preference panes, extensions and other things that have nested on my system over the years. Not all are up-to-date, not all follow the latest requirements of the system.

 

I am yet to find out which was the culprit. I have to find time to re-install and reproduce the problem.

 

My question to you: are you using apps such as Avast, Malwarebytes, Acronis, LittleSnitch, Parallels....? Any of those may have services, helpers or daemons running that interfere.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...