Jump to content

Allow Alfred to quit apps on Catalina


tbrown

Recommended Posts

Since updating to Catalina, the 'quit' command in Alfred can't quit apps that are not listed as those that Alfred can control under System Preferences/Privacy/Automation. 

 

For example, on my system, I allow Alfred 4 to control Scrivener and I can quit Scrivener from Alfred. However, Kitematic is not listed and an Alfred command to 'quit Kitematic' does nothing. 

 

I can't figure out how to get other apps on this list do Alfred can control them. Dragging and dropping doesn't work to this panel. How do I fix this?

Link to post

Sounds like a bug in Alfred/Catalina.

 

For the time being, you could try Kill Process workflow instead. That should still show the apps, and should prompt Catalina to show the "Allow Alfred to control App XYZ" you need to get Alfred to see the application. You may not want to completely replace Alfred's "quit" command with the workflow, though, as it does the equivalent of "Force Quit".

Link to post

@tbrown would you mind temporarily trying a new user account and seeing what Alfred's behaviour is?

 

I actually did a fresh install of Catalina yesterday, installed Alfred 4, and even with Alfred not listed in the macOS Accessibility or Automation preferences, Alfred is able to quit any app using the quit command just fine. (Alfred uses a macOS Public API call to quit apps).

 

Cheers,

Andrew

Link to post

I tried with with another user, and you are correct. There are not entries in Accessibility or Automation Preferences, but Alfred can quit applications without issue.

 

Also, having forgotten about 'forcequit' in Alfred, I tried that from my user account. While I cannot 'quit' apps not list in automations preferences under my account, I can 'forcequit' them without issue. Not something I want to do routinely, I expect, but interesting.

 

Link to post

Turns out this is not quite as simple as I first thought. On my account, for example, Preview.app is in the Automation Preferences list under Alfred 4, but I cannot quit it. Pages is not, but I can quit it. 

 

Confusing, and I have no idea what the difference might be.

Link to post
22 hours ago, tbrown said:

Confusing, and I have no idea what the difference might be.

 

I'm not running Catalina, so I can't say this definitively, but presumably Preview.app is considered to be part of the OS, whereas Pages is an-app-made-by-app-not-tied-to-the-OS.

 

To put it another way: you download Pages from the Mac App Store, whereas Preview comes with the OS.

Link to post

I don't think this has anything to do with whether the apps in question are part of the OS installation. Also, at this point, although I have no idea why, I currently do not have the problem. I can now quit Preview, for example. For the last day or so, I have been able to quit any app I tried to quit. 

 

I have had other fascinating Catalina problems I have been trying to understand. One is that Better Touch Tool takes a lot of CPU time, and particularly, is directly related to causing the Dock.app process to periodically take a lot of CPU time. This results in stuttering in the UI--typing, scrolling, etc. Not running Better Touch Tool fixes this. 

 

Similarly, I have stopped using a number of other background utilities to see if they affected the CPU time issue. My system now runs quite smoothly again. It is quite possible that some strange interaction between Catalina and these utilities was causing the problem with Alfred and that is why it now works. 

 

These problems are very complex and have many interactions. I don't pretend to understand yet.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...