Jump to content

Can not search self-installed-Apps in Spotlight on Catalina


hzlzh

Recommended Posts

Still didn't work. :(

 

1. System Preference - Spotlight -Privacy - "/Applications" + "/System/Volumes/Data//Applications" 

2. then delete them.

3. Alfred - Rebuild macOS metadata

4. open Spotlight search something, then Spotlight will re-index all you files

 

Screen Shot 2019-11-03 at 12.24.01.png

Screen Shot 2019-11-03 at 12.25.19.png

Link to post

@hzlzh The metadata tool for Firefox shows that this isn't being indexed by macOS. Until this is the case, Alfred and Spotlight won't be able to find it.

 

It looks like you've followed the recommended steps we suggested.

 

[Moving to Discussion and Help, as the bugs forum is for Alfred bugs]

Link to post
  • Andrew changed the title to Can not search self-installed-Apps in Spotlight on Catalina

@Andrew Yes I've tried those ways

1. Alfred "Reload Alfred Cache"
2. Alfred - Feature - Default Search - Search Scope - "/Applications"
3. Alfred - Advanced - [Clear Application Cache] + [Rebuild macOS Metadata]
4. System Preference - Spotlight -Privacy - "/Applications" + "/System/Volumes/Data//Applications"

5. brew cask install onyx

 

still not work for me

Link to post

@hzlzh Focusing on trying to fix things in Alfred is the wrong approach, the underlying OS / macOS indexing isn't working. If you are installing Onyx, and enabling root on your Mac, you are past the point where any further suggestions from me will be relevant.

 

Have you been using the macOS Catalina Betas? Or did you upgrade to Catalina? If so, something may have become corrupt during this process, and you may simply benefit from a fresh Catalina install (i.e. format and reinstall, not just install over the top).

Link to post
  • 2 weeks later...
On 11/4/2019 at 6:12 PM, Andrew said:

@hzlzh Focusing on trying to fix things in Alfred is the wrong approach, the underlying OS / macOS indexing isn't working. If you are installing Onyx, and enabling root on your Mac, you are past the point where any further suggestions from me will be relevant.

 

Have you been using the macOS Catalina Betas? Or did you upgrade to Catalina? If so, something may have become corrupt during this process, and you may simply benefit from a fresh Catalina install (i.e. format and reinstall, not just install over the top).

I did not use beta OS, also I had tried OnlyX to re-index spotlight, no help still.

Screen Shot 2019-11-14 at 00.22.17.png

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...