Jump to content
luckman212

Weird click behaviour in popup menu for workflow editor [Workaround in 4.0.6 b1124]

Recommended Posts

  • macOS Catalina 10.15.1 (19B88)
  • Alfred 4.0.6 b1123

 

I've run into a weird problem in the workflow editor. Not sure when it began, but I think around 4.0.4 / 4.0.5 I started noticing it.

 

The problem is, clicking the little colored box UI elements to change an object's color only works on the upper 50% of the pixels in the tiny square.

E.g. clicking here does work:

clip-86ccd9.png.b48815290b02d918d1e6bc562d9ac49b.png

 

but clicking here does nothing (menu does not close even after several clicks). This is strange and I'm 99.9% sure this wasn't an issue before.

clip-0bd6f5.png.b40fd727cf790bd0ee834e971dc3f89e.png


 

Share this post


Link to post

@luckman212 this looks like a Catalina bug as you also have to click the top half of the normal menu items too, such as the "Edit Note..." item above the colours.

 

I'm not sure there is much I can do to work around this behaviour 😕 

Share this post


Link to post

I’m on Mojave and cannot replicate, so it does seem like a Catalina bug.

 

58 minutes ago, luckman212 said:

Should I report this to Apple or do you think they already have enough?

 

If it’s not reported now, it may never get fixed. Under “Regressions Get Fixed. Old Bugs Get Ignored”:

 

Quote

But if you file a bug report, and the QA engineer determines that bug also exists in previous releases of the software, it’s marked “not a regression.” By definition, it’s not a new bug, it’s an old bug. Chances are, no one will ever be assigned to fix it.

 

Share this post


Link to post

I filed a bugreport (#FB7432657) under the category "Menu Bar > Incorrect/Unexpected Behavior" - the title is "Menu item click area is not aligned correctly / does not respond to clicks properly" in case anyone else wants to report this. Please use the exact same Title and Category so hopefully this gets noticed.

 

Xnip2019-11-07_08-54-17.png.ca6b24a9097c90171118450a13a6df0d.png

 

Share this post


Link to post
Just now, luckman212 said:

Please use the exact same Title and Category so hopefully this gets noticed.

 

It might be best if you post the exact text (for easy copying and resubmission). Allegedly, duplicate bug reports help push it up the ladder.

Share this post


Link to post

Good idea @vitor — here is the text for copy & pasting:

 

Menu item click area is not aligned correctly / does not respond to clicks properly

 

Since updating to 10.15.1 (19B88) popup menu items in Alfred 4.0 and possibly other applications are not responding to clicks correctly.

It seems like the UI element / bounding box that receives the click event is not aligned properly, so that clicks in the lower 50% of the UI element do not trigger the item - only clicks on the UPPER portion of the menu item are working.

 

I posted a bit of detail + some screenshots on the Alfred forum:
https://www.alfredforum.com/topic/13957-weird-click-behavior-in-workflow-editor-406-b1123/

 

Share this post


Link to post

@luckman212 thanks for reporting this to Apple.

 

I've been playing with it a little more this morning and have gathered a bit more info on the underlying behaviour. Essentially, when a custom view is assigned to a menu item, Catalina is not passing mouse up events for the bottom ~9 pixels of the menu item, even though mouse moved events are still being passed (hence the colour items showing the hovered colour correctly).

 

When I get a moment, I'll create a simple test case app and report a bug to Apple too.

 

I've just done the 4.0.6 release, and have "worked around" this issue by doing two things.

  1. Added a separator above the colours (where necessary) so that the "Edit Note..." item is no longer affected by the bug
  2. Made the colours slightly larger, and added a 9 pixel inset below the colours which are also ignored in the mouse move, so Alfred treats the Catalina bugged "dead zone" as irrelevant.

Let me know how you get on with this workaround.

 

Cheers,

Andrew

Share this post


Link to post

@Andrew Thank you heartily for trying to work around this (silly) bug! After updating to 1124, I tested again and found a few rough spots where the clicks weren't registering, even with the workaround. It was basically the bottom 2 pixels of the color boxes (clicking on the 3rd px up from the bottom always worked). I had a nice screencapture video recorded and annotated with details—but then of course my capture program (Capto) crashed and I lost it all.  And lo and behold, now I can't reproduce the problem. So it's all for the best. Thank you again! 😃

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...