Jump to content
Sign in to follow this  
191919

Display performance degradation on 10.14.6 with 5K 10bit display

Recommended Posts

I just upgraded my Mac Pro from 10.13.6 to 10.14.6 and found there was a severe display performance degradation, if running on a 5K display under 10bit color depth mode.
 
In 10.13, Alfred always shows the expected results in almost zero latency, but since the OS upgrade to 10.14.6, there is always a delay of 100ms-200ms before the icons of the results are shown.
 
After some efforts, I found the performance impact is due to the color depth of the display. If I use the default color profile (Dell 2715K, 10-bit color), the problem can always be reproduced. If I switch to "sRGB IEC61966-2.1" (sRGB, 8-bit color), even in 10.14.6, there won't be any performance impact, i.e., the icons appear as quickly as in 10.13.6.
 
Another place of performance degradation is Alfred Preference's Help tab, when the mouse is hovering over an icon (Getting started/Help and Doc/Report a bug/User forum), the icon becomes green, but before it does, there always is a delay of 100-200ms.
 
If I switched to sRGB color space, there is no delay before the icon becomes green if the mouse is hovering over the icon, and all the renders are performed in ARGB32 which is done very fast.
 
I ran Instruments on Alfred Preference to find why. It turns out that two RGBAf16 functions ate almost 97% of CPU, but that pixel format should not be used.
 
Running Instruments on Alfred also shows resample_float16_h_cpp, __extendhfsf2 and _truncfhf2 ate over 80% of CPU, where RGBAf16 was also used but shouldn't be.
 
I believe the use of RGBAf16 is the reason of slow rendering speed of both Alfred search result list items and Alfred Preferences Help tab icons.
 
The screenshot files are too big to fit within 1MB, I have sent emails to info@.

Share this post


Link to post
Share on other sites

I've seen your email on this, and this is the first time this has cropped up.

 

What's interesting here is that Alfred isn't doing anything particularly special / low level for rendering these. For example, the Preferences tab, l am simply overriding the drawRect of an NSView and doing some simple NSBezierPath rendering. Alfred isn't defining or limiting the colour profile in any way.

  1. Are you seeing performance issues with other apps?
  2. Have you installed any 3rd party drivers or extensions to get your Dell display to "render properly" which could be interfering?
  3. Have you tried on a fresh user profile to see if there is any underlying issue on your main profile?
  4. Have you reported this issue to Apple, as fundamentally, this is going to be a system wide OS issue?

Cheers,

Andrew

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...