Jump to content

[SOLVED] Alfred no longer indexing applications


Recommended Posts

OSX 10.15.1 Catalina

Alfred 4.0.6 (1124)


Alfred is no longer indexing some of my applications. It still shows the Apple apps (Photos, Music, etc.) however no third party apps are showing up. They are also not showing up in Spotlight either, so this must be a problem in general with Spotlight indexing.  I've tried Advanced -> Clear Application Cache and Advanced -> Rebuild macOS Metadata, but none of those helps. (I have let "Rebuild MacOS Metadata" run overnight.) Also when I try the "Delete .Spotlight-V100 before reindex" I get the following error: "rm: /System/Volumes/Data/.Spotlight-V100: Operation not permitted". Any ideas?

Link to post
17 hours ago, luckman212 said:

@dburr as you rightly concluded, if Spotlight doesn't show the apps, Alfred isn't going to be able to either. Sounds like something's majorly hosed with your Spotlight db. I'd follow Apple TN HT201716 for getting that rebuilt, or try `sudo mdutil -Ea` from Terminal.


Thanks for the response! I was actually able to figure out how to fully rebuild Spotlight. Ended up booting into recovery mode to delete the /.Spotlight-V100 file, then I rebooted and let it run overnight, and now both Spotlight and Alfred are properly indexing things again.

Link to post
  • vitor changed the title to [SOLVED] Alfred no longer indexing applications

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...