Jump to content

Alfred doesn't respond when waking from sleep


Recommended Posts

I seem to have this intermittent issue where Alfred just doesn't respond when my machine wakes from sleep.

 

Info
 

  • What you were doing when the issue happened
    Woke the machine up from sleep
  • Whether you were able to replicate it a second time by performing the same action
    Nope. Happens intermittently.
  • Include any screenshots that might help us
    Unfortunately no. There's no visual symptom. Alfred just doesn't respond.
  • Include the Alfred version & build number you are using
    Alfred 4.0.6 [1124]
  • Include your OS X version
    macOS Catalina 10.15.1 (19B88)

 

Other information which might possibly be relevant

  • I'm using CMD + SPACE as my hotkey (replacing Spotlight)
  • I use Karabiner version 12.8.0. This also malfunctions on occasion which may be a contributor to this problem - but I have no clue.

 

Please let me know if you need any other information that you think might help. Thanks!

 

 

Link to post
Share on other sites

@ionstorm Thanks for providing some details; Here are a few more questions to help establish what's going on :)

 

  • Do you sync your preferences? If so, to what service and what is the exact path? There's a possibility that if you're using a service where the file isn't available on wake (e.g. Google Drive), Alfred doesn't think you have any customisations and reverts to default preferences, in which case he'd switch back to Alt + Space, the default hotkey.
  • Do you have an external screen? Do you plug and unplug from it? Some users have reported Alfred not appearing on screen after wake, but it turns out that Catalina has mis-configured the screen dimensions and Alfred is really appearing off the visible screen. In that case, you should be able to use your hotkey, blindly type an app name and launch it.
  • Do you have any errors in Console after wake?
  • If you fully quit Karabiner and any other apps that may be interfering, does the issue still occur?

Cheers,
Vero

Link to post
Share on other sites
  • Do you sync your preferences?
    No, I don't sync my prefs.
  • Do you have an external screen? Do you plug and unplug from it?
    Yes I do! I'll try this out. 
    I'll have to check when I encounter this next.
  • Do you have any errors in Console after wake?
    I'll have to check when I encounter this next.
  • If you fully quit Karabiner and any other apps that may be interfering, does the issue still occur?
    I'll try the two above first and then i'll come around to this.

Thanks!

Link to post
Share on other sites

I am experiencing exactly the same with Alfred 4.0.7 pre-release

 

  • Do you sync your preferences?
    yes via dropbox
  • Do you have an external screen? Do you plug and unplug from it?
    yes I am using external and yes plug and unplug
  • Do you have any errors in Console after wake?
    Need to check next time
Link to post
Share on other sites

@Acidham When you think Alfred isn't responding, could you please type an app name and hit return to see if the action is performed anyway?

 

As I've just explained to a user in this thread, I suspect that Catalina is failing to calculate the size of the visible screen properly, so Alfred is actually appearing off-screen. Take a look at the suggestions I've made (in the post I've linked and my most recent one at the bottom of that thread) and let me know how you get in.

 

I'd be really grateful for some input as we've been unable to replicate this issue and I'd like to have a clearer idea of what's going on for the users who are seeing this.

 

Cheers,
Vero

Link to post
Share on other sites
  • Vero locked this topic
Guest
This topic is now closed to further replies.
×
×
  • Create New...