Jump to content
dirtrider

Alfred search on network volume not working, though Spotlight is

Recommended Posts

I have a Synology share mounted on my Mac. I enabled a Spotlight index via

mdutil -i on /Volumes/filecabinet/

Spotlight searches are now working as expected on that volume, but Alfred searches are not. I am using a file filter workflow for searching document contents. I am pretty certain the workflow is configured properly, because if I temporarily add a local volume to the Scope, I get the search results I expect. The "in" built-in search method is also not working on this volume.

 

I figured this was a Catalina incompatibility with Alfred 3.x, so I upgraded my Alfred and Powerpack -- still no dice.

 

Any ideas on this?

 

Catalina 10.15.2

Alfred 4.0.7

Share this post


Link to post

Thanks @vitor. I had not seen that guide and the Catalina troubleshooting doc it links to, but, yeah, I had tried all of those steps.

 

Spotlight works fine on the target volume. Alfred searches work as expected on local volume.

 

Any help appreciated.

Share this post


Link to post

I have this same problem.  Files on local drives found by Spotlight and Alfred.  But files on mounted drives are found by Spotlight but *NOT* Alfred.  

 

Already tried the Troubleshooting as recommended above by Vitor.

 

macOS 10.15.5

Alfred 4.0.9 

Share this post


Link to post

@dp_ucsd Could you please update to Alfred 4.1, go to Help > Troubleshooting > Run Troubleshooting, and drag in a few files from your mounted drive?

 

Please paste the output here so that we can take a look at what might be missing for Alfred to search your mounted drive. :)

 

Cheers,
Vero

Share this post


Link to post

Where/how do I update to 4.1?  Within the app, "Check for updates" says "You are already using Alfred 4.0.9 [1144]" and merely shows the Change log regarding previous versions.  If I go to alfredapp.com and choose "Download Alfred 4", it downloads Alfred_4.0.9_1144.dmg, which by the filename I assume is still that same version.

Share this post


Link to post
1 minute ago, dp_ucsd said:

Where/how do I update to 4.1?

 

There’s a dropdown on the bottom of the Updates tab in Alfred Preferences. Change it from updates to pre-releases.

Share this post


Link to post

here is the Troubleshooting output:

 

Starting Diagnostics...

File: 'pathways.png'
Path: '/Users/dap/from MBP/awip/BG circuits'

-----------------------------------------------------------

Check file cache database...

File cache integrity is ok

-----------------------------------------------------------

Check if file is readable...

Alfred has permissions to read this file.

-----------------------------------------------------------

Check file is in search scope...

File exists within Alfred's default search scope

-----------------------------------------------------------

Check if volume '/' is indexed by macOS...

Indexing is enabled on this drive

-----------------------------------------------------------

Check direct file metadata...

⚠️ Direct metadata is missing, this file is likely not indexed

Display Name: 
 Other Names: 
Content Type: 
   Last Used: 

-----------------------------------------------------------

Check mdls file metadata...

Metadata missing essential items

-----------------------------------------------------------

Troubleshooting failed
 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...