Jump to content

Google Won't Let Me Log In to Use Alfred Workflows


Recommended Posts

Hi guys! I just got Alfred and love it so far, but one thing annoys me. I'm a Google guy and so I have downloaded the workflows for Google Calendar and Drive. 

 

But none of them work. Google doesn't allow me to login using these apps.

 

When it comes to Drive, it just tells me "Google login has been deactivated for this app." As for Calendar, it tells me that the app isn't verified. If I click on advanced I can open Alfred Calendar Summary in unsafe mode, then it leads me to a localhost page which simply says "ok". But things aren't ok, I am still not logged in and can't use the app.

 

I will of course raise this to respective workflow developer, but I suspect there is a general problem for me to connect Google and Alfred, and I wonder if there's a general way to solve it?

 

Thanks!

Link to post

@Micael Welcome to the forum!

 

Could you provide links to the exact workflows in question? There are quite a few Google-related community-created workflows, so links will allow us to take a look at which ones you're using :)

 

If there are already threads for those workflows on the forum, that would be your ideal starting point; Post a detailed message in that thread, letting the workflow creator know which version of macOS and Alfred you're using (and Google Drive version, as I believe there are a few for personal or business use), and exactly what error messages you're getting. 

 

Alfred doesn't connect to Google, so it'll be something between the workflow and Google (which could be as simple as the workflow needing a little update if Google have updated some APIs or landing pages the workflow relies on).

 

Cheers,
Vero

Link to post

Welcome @Micael,

 

1 hour ago, Micael said:

I will of course raise this to respective workflow developer

 

That is indeed the best course of action.

 

1 hour ago, Micael said:

but I suspect there is a general problem for me to connect Google and Alfred

 

That is unlikely, from your descriptions.

 

1 hour ago, Micael said:

When it comes to Drive, it just tells me "Google login has been deactivated for this app."

 

That’s caused by Google itself and should affect all users of the Workflow.

 

1 hour ago, Micael said:

As for Calendar, it tells me that the app isn't verified.

 

That’s caused by macOS. You’ll need to peer into the Workflow’s directory, find the app/executable in question, right-click it and pick Open. You should get the same warning, but this time with an option to open it anyway. Do it once and it should start to work without further prompts.


Naturally, keep in mind that as with all software you should only do it if you trust the source/author.

Link to post
5 hours ago, Micael said:

I will of course raise this to respective workflow developer, but I suspect there is a general problem for me to connect Google and Alfred, and I wonder if there's a general way to solve it?

 

It has nothing to do with Alfred. It is specific to Google and the workflows. It sounds like you might be using my Google Calendar workflow. The "ok" message indicates that it is connected to Google, so please check the workflow's log file for an error.


If there's nothing obvious, please take the discussion to the workflow's issue tracker or its forum thread:

 

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...