Jump to content

Apple script - Log not working?

Recommended Posts

I can't find any way to output anything from "Run NS Apple script" into debug console.

My script looks like this:



And when I run it, it doesn't output "Something" in the console. Console looks like this after I run the script:



Here's how workflow looks like (very basic, just to test the console output):



My Alfred version is 3.8.6

Osx Catalina 10.15.3





Edited by chavlji
Link to comment
8 hours ago, chavlji said:

But why is first log always printed out as an error?


Because older versions of Alfred always prefixed log messages with ERROR.


Also, all three messages are being printed as "errors": as far as Alfred is concerned they're all one single message with some newlines.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...