Jump to content

Microsoft ToDo (Wunderlist replacement) workflow


Recommended Posts

Sharing a basic Alfred3 workflow for Microsoft Todo for anyone migrating over to ToDo as of Wunderlist's shutdown tomorrow. Alfred is my go-to for controlling Mac and the efficiency of adding and searching tasks via the workflow is something that I was going to miss with a move to another to-do list, so I decided to make a fork of prior work here. PRs welcome!

 

https://github.com/johandebeurs/alfred-mstodo-workflow

Edited by vitor
Made link clickable
Link to comment

Thanks so much for doing this! Alfred integration has been one of the biggest things I've missed about Wunderlist since switching to Microsoft ToDo. 

 

Unfortunately, I can't seem to get it to work. I downloaded the workflow and double-clicked on it and it appears to install properly, but when I type "td" in the Alfred box, all I get is the application—I don't see the options visible in your screenshots. I tried disabling and reenabling and deleting and reinstalling, as well as quitting Alfred altogether. What am I missing?

 

Thanks for any help you can provide.

 

Ben

Link to comment

Here is the error message in the debugging panel.

 

[06:39:54.052] Logging Started...
[06:39:56.942] Microsoft ToDo[Script Filter] Queuing argument ''
[06:39:57.146] Microsoft ToDo[Script Filter] Script with argv '(null)' finished
[06:39:57.148] ERROR: Microsoft ToDo[Script Filter] Code 1: Traceback (most recent call last):
  File "alfred-mstodo-workflow.py", line 8, in <module>
    fileConfig('/Users/johan/Documents/Programming/Alfred workflows/alfred-mstodo-workflow/src/logging_config.ini')
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/logging/config.py", line 77, in fileConfig
    formatters = _create_formatters(cp)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/logging/config.py", line 113, in _create_formatters
    flist = cp.get("formatters", "keys")
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/ConfigParser.py", line 607, in get
    raise NoSectionError(section)
ConfigParser.NoSectionError: No section: 'formatters'

 

Link to comment
  • 3 months later...

Hi @jdb, thanks you so much for the workflow ! Of late I have been running in to authentication issues which I am not sure how to resolve, I tried to login to todo website and see if something pops up to authenticate the workflow but I dont see anything. Not sure what happened, I am seeing this issue for the second time and I dont remember how it got resolved the first time..

 

===================================================

 

[10:53:36.306] Microsoft ToDo[Script Filter] Queuing argument ''

[10:53:36.880] Microsoft ToDo[Script Filter] Script with argv '(null)' finished

[10:53:36.884] ERROR: Microsoft ToDo[Script Filter] Code 1: .

2020-09-08 10:53:36,852 workflow     ERROR    

Traceback (most recent call last):

  File "/Users/hk890008/alfred/Alfred.alfredpreferences/workflows/user.workflow.165812FE-AFC5-4F5C-B9BB-928AA638E604/workflow/workflow.py", line 2073, in run

    func(self)

  File "alfred-mstodo-workflow.py", line 17, in main

    route(wf.args)

  File "/Users/hk890008/alfred/Alfred.alfredpreferences/workflows/user.workflow.165812FE-AFC5-4F5C-B9BB-928AA638E604/mstodo/handlers/route.py", line 18, in route

    logged_in = is_authorised()

  File "/Users/hk890008/alfred/Alfred.alfredpreferences/workflows/user.workflow.165812FE-AFC5-4F5C-B9BB-928AA638E604/mstodo/auth.py", line 57, in is_authorised

    return resolve_oauth_token(refresh_token=workflow().get_password(config.KC_REFRESH_TOKEN))

  File "/Users/hk890008/alfred/Alfred.alfredpreferences/workflows/user.workflow.165812FE-AFC5-4F5C-B9BB-928AA638E604/workflow/workflow.py", line 2445, in get_password

    account, '-g')

  File "/Users/hk890008/alfred/Alfred.alfredpreferences/workflows/user.workflow.165812FE-AFC5-4F5C-B9BB-928AA638E604/workflow/workflow.py", line 2813, in _call_security

    raise PasswordNotFound()

PasswordNotFound

[10:53:36.888] Microsoft ToDo[Script Filter] <?xml version="1.0" encoding="utf-8"?>

<items><item valid="no"><title>Error in workflow 'Microsoft ToDo'</title><subtitle /><icon>/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/AlertStopIcon.icns</icon></item></items>

Link to comment
  • 1 year later...

@jdb Does this workflow work in MacOS 12 Monterey? When I try to log in, it seems to be working and then I get this message in my browser. I think that deleting the keychain entry fixed this in the past but it is not doing the trick. 

 

Access to 127.0.0.1 was denied

You don't have authorization to view this page.

HTTP ERROR 403
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...