Jump to content

Why Alfred. doesn't show contacts??


Recommended Posts

Hello, just installed Alfred, wonderful software.

 

I don't know why, Alfred doesn't find contacts in my system.

 

When I try to grant access to contact via preferences it doesn't work.

In my Security and privacy settings, Skype are granted in Contacts, but no Alfred.

 

I use 4.0.9 version [1144] and Catalina 10.15.4.

 

 

Any Idea??

Screenshot 2020-05-11 at 06.42.09.png

Link to post

@Daniele I'm re-posting the response Andrew provided you by email, in case this is useful to other users in the future:

 

On starting Alfred, macOS should present a dialog requesting access to Contacts. If you deny access, you should still see Alfred listed in the macOS Privacy > Contacts screen, just unchecked.

 

If this isn't happening, there could be a permissions issue in macOS which is preventing this from happening. You can try using a macOS Terminal command to reset the underlying permissions for this. You can do this by quitting Alfred, then pasting the following command into Terminal.app:

 

sudo tccutil reset AddressBook

 

When you restart Alfred, you should be presented with this dialog by macOS:

 

unnamed.png

 

I have also deleted the bug thread you started on this topic. We respond as quickly as we humanly can, so there's no need to post multiple times for the same question.  :)

 

Cheers,
Vero

Link to post

Hello Vero, 

 

yes, indeed, I post two times same issue. Sorry for that, first time here for me.

 

About the problem.
first of all, thank you for your help.

I tried several times with a that command.

In specific:
-Quit Alfred
-in Terminal: sudo tccutil reset AddressBook
-Open Alfred : it doesn’t work.

I also tried to restart system before open Alfred. nothing.

Also tried to erase and reinstall Skype, just to check if it ask for access to my contact, and yes, the popup come and I can put access. Skype yes, but why Alfred can't??

For some weird reason, it seems that Alfred doesn’t ask me to give it access to my contact.

Just for curiosity I installed Alfred on my Mac with High Sierra, and it works perfectly. But why on my Macbook with Catalina don't ???

 

Just sent to Andrew also two video file for better explain.

 

Thank you always for your kind support

Daniele
 

Link to post

@Daniele Could you please temporarily create a new user account on your Mac where you're seeing this issue? When you request Contacts permissions, are you able to set them on this new profile?

 

Let me know how you get on. 

 

Cheers,
Vero

Link to post

Vero, unfortunately it doesn't work.

 

Create new user ->

logout ->

login with new user ->

launch alfred ->

-> wizard of Alfred as first opening

-> ask me all permission  except for Contacts.

 

Exacly the same with my account.

 

It's a weird story, really.

 

What could I do???

Link to post

@Daniele This is extremely strange, and the first time I've heard of this behaviour. I assume you've tried re-downloading the Alfred dmg and replacing Alfred in /Applications/ with a fresh copy, just in case something has become corrupted?

 

Cheers,

Andrew

Link to post

Yes I obviously tried before contact you. Deleted with AppCleaner, removed items on login items, and installed again new fresh copy.

 

Any remote assistance??? 

 

Sorry I don't want to bother you, really

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...