Jump to content

Lock doesn't work in Catalina 10.15.4


Recommended Posts

Hi. For some reason the 'Lock' option doesn't work.

 

Alfred version: 4.0.9 [1144]

 

I have checked the permissions using 'Request permissions...'. Under 'Automation' I have this:

 

 image.png.77e859caeed6cf83bb79001b1dcf9d30.png

 

and under 'Accessibility' there is no Alfred icon/checkbox at all.

 

I tried checking the Console.app whilst running the 'Lock' option from Alfred. The only thing I see in the log from Alfred is a few of these when I start typing:

 

"Starting query at qos 0x19"

 

When I select 'Lock', there is nothing added to the Console.app log.

 

Link to post

Hi Andrew

 

Alfred is already present under 'Prefs > Security & Privacy > Privacy > Automation' (as per the screenshot). For 'Prefs > Security & Privacy > Privacy > Accessibility' I used [+] to manually add Alfred 4, however this made no difference. The Alfred 'Lock' command still does nothing. 

Link to post

@Joe Littlejohn Are you using any third-party tools like Karabiner or other keyboard remappers that may be interfering with normal hotkey operations?

 

If so, try quitting them (not just disabling) and seeing whether it then works.

 

Cheers,
Vero

Link to post

Ah, thanks Vero. I'm not using Karabiner but your comment reminded me that yes, I have remapped the lock screen keyboard shortcut using Prefs > Keyboard > App Shortcuts! Thanks for the help, I had forgotten that I had had to change the mapping for 'Lock Screen' because it conflicted with another app.  

 

So I guess this means Alfred uses a simulated keyboard shortcut to activate the screen lock? Is there any way I can work around that? Can I customize the shortcut that Alfred triggers?

Link to post
Posted (edited)
On 5/11/2020 at 11:05 AM, Andrew said:

@Joe Littlejohn You can disable the built-in lock keyword, then create a simple workflow with a Keyword -> Dispatch Key Combo.

 

Set the keyword to "lock", and the key combo to whatever you'd like it to be!

 

Sure, that's a workaround -- but the built-in command seems to now be broken.

 

I'm on 10.15.4 and seeing the same issue. Just used the built-in "lock" command and nothing happens. I know I've used it in the past successfully. I'm not using Karabiner or any other key remapping software. 

Edited by octothorpe
Link to post

@octothorpe if you manually use the macOS lock combo of control+command+Q does this lock your Mac?

 

If so, try quitting Alfred, then removing him from the macOS Security & Privacy > Privacy > Accessibility preferences, and re-adding him back again. If there is an underlying mismatch in the macOS privacy prefs, Alfred may have been blocked from simulating a lock.

 

If this combo doesn't work, then you can check what combo is expected under the Apple logo in the top right of your screen for "Lock Screen". This is the combo you'll need to manually configure in a workflow.

 

Cheers,

Andrew

Link to post
10 hours ago, Andrew said:

@octothorpe  try quitting Alfred, then removing him from the macOS Security & Privacy > Privacy > Accessibility preferences, and re-adding him back again. If there is an underlying mismatch in the macOS privacy prefs, Alfred may have been blocked from simulating a lock.

 

Aha, this did the trick. 

 

It also solved another issue I was having related to snippets not working. I'll post in the other thread as well. Thanks!

 

 

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...