Jump to content

[SOLVED] Snippets broke somehow


Recommended Posts

Not sure why or how, but none of my snippets work any more. I can bring them up just fine in the Alfred window as I always have, but when I select one and hit return it fails to paste into my text as it always has before.

 

I'm working on a brand new MacBook I just got, which I migrated everything into from a Time Machine backup (using Migration Assistant). I insured that all of Alfred's requested permissions have been granted. All my preferences look the same way they always have, so I'm a bit stumped. 

Link to post

@octothorpe Based on your screenshot of the preferences, it doesn't look like you've activated snippet auto-expansion; You'll need to check the box that says "Automatically expand snippets by keyword".

 

Edited to add: I see you're talking about pasting from the viewer rather than expanding... In that case, if you make TextEdit your frontmost window, and try pasting a snippet there, do you get the expected behaviour? It's best to test in a basic native app, as a third-party app or browser window might have some other funky stuff going on that affects the ability to paste to it.

 

Cheers,
Vero

Link to post
9 hours ago, Vero said:

@octothorpe Edited to add: I see you're talking about pasting from the viewer rather than expanding... In that case, if you make TextEdit your frontmost window, and try pasting a snippet there, do you get the expected behaviour? It's best to test in a basic native app, as a third-party app or browser window might have some other funky stuff going on that affects the ability to paste to it.

 

 

Yes, exactly -- I'm interested in the pasting option, which has always worked brilliantly for me in any app. And for that I've never had "automatically expand..." checked. 

 

I just tested in TextEdit and it doesn't work. The list comes up normally in Alfred, but nothing ever gets pasted in. 

Link to post
Posted (edited)

OK, this is fixed now -- turns out I had to remove Alfred from the Accessibility panel and re-add him per @Andrew's instructions. See the post below for details. Two birds, one stone!

 

 

Edited by octothorpe
Link to post
  • vitor changed the title to [SOLVED] Snippets broke somehow

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...