Jump to content

[SOLVED] New main drive, not finding Applications now

Recommended Posts

Last weekend, I swapped my primary drive in my Trash Can Mac Pro to a new one. It went swimmingly.


Alfred no longer finds anything in my /Applications folder.


I've tried: Rebuilding macOS Metadata, Clear Application Cache, removing and readding the directory to my settings. It's still not finding any of my Apps.


What am I missing?

Link to post
Posted (edited)

@mikejandreau Could you go through the indexing troubleshooting steps here?



In particular, if you follow step 4, once you get to Terminal, do you see "Indexing enabled" or any error message relating to indexing?


Can Spotlight find the apps and open them?


If you install the Metadata tool (https://cachefly.alfredapp.com/tools/AlfredMetadataTool_v1.1.zip) and drag in some apps, is their metadata complete? (Paste the output here so that we can help you further)



Edited by Vero
Fixed the indexing link for posterity... :)
Link to post
Posted (edited)

Hey @Vero


That URL redirects to https://www.alfredapp.com/help/troubleshooting/indexing/mdls/ so I don't see a step 4 there to try.


I did re-enable Spotlight in Bartender and it's not finding any of my Applications either, so something's amiss there.


I ran some checks on that, and it looks like Spotlight indexing and searching is disabled on the new drive:

	Indexing and searching disabled.
	Indexing and searching disabled.

The normal commands to get it running aren't working, but I can't figure out why. I'll contact the manufacturer of my new drive and see what they say.


Also the Metadata tool can't get Metadata for any of my apps. The ones I tested come back with "Unable to obtain metadata for this file!". So something's amiss here.

Edited by mikejandreau
Link to post

As usual, I spent half an hour trying to re-enable Spotlight on the new drive in Terminal, fighting everything along the way.


Come to find out, there's a setting that for some reason was running against the new Drive:



My new drive _was_ list there. Removed it. Rebuilt the cache in Alfred and voila, magic.


Thanks for pointing me in the right direction @Vero!

Link to post
  • vitor changed the title to [SOLVED] New main drive, not finding Applications now

I spoke too soon, re-enabling Spotlight didn't seem to fix the issue.


The Metadata checker finds the right info now and permissions all look good, but most of my apps still don't get found by Alfred.


What else can I try?

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...