Jump to content
grkngls

Workflow to set command in terminal on remote computer

Recommended Posts

Hi

 

I'm running a Raspberrry Pi with Pi-Hole. And I want a workflow to disable the pi-hole from my mac.

 

I use the "Run Script" with following commands:

 

ssh pi@192.168.178.3
pihole disable

Language is set to /bin/bash/

 

But I didn't get an error nor did the pi-hole disable. Sure I can enter the same command local from my mac - it's working.

 

What am I doing wrong?

 

 

regads from germany

grkngls

Share this post


Link to post
15 hours ago, grkngls said:

I use the "Run Script" with following commands

 

It won't work that way because we're talking about a script here, not an interactive shell session. When you run your first command (ssh pi@...) in an interactive shell, it opens an SSH session on the remote machine, and you are actually entering your second command in the SSH session.


You can tell SSH to run commands on remote machines, though, and yours would be something like: ssh pi@192.168.178.3 pihole disable

 

Share this post


Link to post

I do this, but use sshpass like this:

 

sshpass -p yourpasswordhere ssh pi@pihole 'pihole disable'

 

sshpass is not installed on Macs by default. I installed using home-brew. Be sure you understand any security issues this may cause on your Mac. 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...