Jump to content

[SOLVED] Spotlight not indexing directories


Recommended Posts

I know this isn't directly related to Alfred, but since it's affecting my use of Alfred, I thought someone here might have some insight.

 

An external drive of mine is acting up in that Spotlight won't index the subdirectories of some of my directories.

 

Alfred finds (because Spotlight has indexed it), for example, /Video/TV Shows, but not /Video/TV Shows/anything-in-there

Same with /Video/Movies, that top level shows up, but none of the folders within.

 

The only thing fishy is that I've explicitly added /Video/TV Shows and /Video/Movies to Alfred. If I remove them from my settings, Alfred doesn't find them (my guess is because Spotlight isn't working)

 

I tried forcing Spotlight to re-index the entire drive, which it looks like it finished because the "Indexing..." in Spotlight is gone, but there's no .Spotlight-V100 file on the drive, like there is with other external drives.

 

I tried forcing it to index with 

sudo mdutil -E /

which shows "Indexing enabled".

 

I'm stumped and wondering if anyone else has any thoughts on what I can try.

 

 

Link to comment

And now, after telling Alfred to rebuild its cache as one last whim, even though I've done it 5 times already, Spotlight seems to have fixed itself.

 

Maybe it was my reboot. Maybe it was luck. But in any case, it seems to have fixed itself, so I'm all good.

Link to comment
  • vitor changed the title to [SOLVED] Spotlight not indexing directories

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...