Jump to content

1Password not working


Recommended Posts

Hello,

 

I realised this afternoon tat 1Password items are no longer opening and autofilling via Alfred.

 

I've tried a few things:

  • updating Chrome/Alfred/my extensions
  • Restarting my computer
  • different profiles in Chrome
  • uninstalled are re-installing both

 

I've recored my screen trying to run twitter (see a gif on this post, and the full recording here on dropbox). You can see Alfred actually brings the. 1Password App in to focus but then nothing happens.

Is this a 1Password bug? And Alfred is fine?


Is anyone else facing this issue, is this a known bug? I think it's been happening for a few days, but I've only just 2 and 2 together this afternoon.

Thanks for the help, Rob

Alfred+1Password.gif

Edited by robgill
Link to post

Looks very much like the problem is at the 1Password end. This is generally to be expected, seeing as that's where all the complexity is (Alfred just asks the system to open a 1Password-specific URL), and historically has been where most issues with Alfred's 1Password integration originate.

 

Link to post

Alfred's modern integration with 1Password is actually extremely simple, he shows a list of items provided by 1Password, and when you select that item, he passes the item back to 1Password for processing (via their URL scheme).

 

Glad that it now seems fixed on their side, but I'll keep an eye on this anyway.

Link to post

How does it handle multiple versions of 1Password (e.g. 1Password regular and 1Password X)? I know previous versions have kept their data in the same place. Is that also true of 1Password X/beta versions?

 

Also, do you have a link to the URL scheme details? I haven't been able to find it. Being able to give users a URL to open would make it easier to demonstrate that the problem is on 1Password's side.

Link to post

Here is the URL scheme info:

 

https://support.1password.com/integration-mac/#open-a-1password-metadata-file

 

At this point, Alfred only officially supports reading metadata from the native 1Password Mac app with its 3rd party integration enabled. If 1Password X had a 3rd party integration output (I don't believe it does), and places it in the same location as the native Mac app, it's likely Alfred will be happy with this too.

 

This page does say that 1Password X integrates with 1Password Beta for Mac though, so this is how I assume you would get the integration working:

 

https://support.1password.com/getting-started-1password-x/

Link to post

Thanks. I knew that Alfred was basically only opening a URL, and figured it was most likely a problem with the support for the URL scheme being screwed up on 1Password's end.

 

I didn't buy the reason/excuse they gave on their forum that "Alfred requires the 1Password extension (desktop app required) instead of `1Password X", as if it's Alfred's fault.

 

They're in charge of whether their own URL scheme works or not.

Link to post
1 hour ago, Andrew said:

Here is the URL scheme info:

 

https://support.1password.com/integration-mac/#open-a-1password-metadata-file

 

At this point, Alfred only officially supports reading metadata from the native 1Password Mac app with its 3rd party integration enabled. If 1Password X had a 3rd party integration output (I don't believe it does), and places it in the same location as the native Mac app, it's likely Alfred will be happy with this too.

 

This page does say that 1Password X integrates with 1Password Beta for Mac though, so this is how I assume you would get the integration working:

 

https://support.1password.com/getting-started-1password-x/

 

Thanks @Andrew but I am unable to get this to work, although I followed the instructions and those from others.

 

I will revert to 1Password, as they need to develop a solution for this.

Link to post
  • 1 month later...

@pubay Welcome to the forum :)

 

When you say the integration "isn't working at all", could you please provide more details?

 

- Have you followed the setup steps here? https://www.alfredapp.com/help/features/1password/

- Are you seeing any bookmarks in Alfred's Features > 1Password preferences?

- If so, are you seeing any results when typing your keyword set in the preferences above? (Or no keyword, just the name of the bookmark, if you've set that option in the preferences)

- Which version of Alfred, macOS and 1PW are you using?

 

The more information you can provide, the more easily we'll be able to help you work out what might be missing in your setup :)

 

Cheers,
Vero

Link to post
  • 3 months later...

@Vero Having the same issue. I followed the outlined steps and all my accounts are showing in Features > 1Password preferences successfully. However, no results are showing when typing a keyword set in preferences. Everything works fine if "Show in default results without keyword" is selected. Running Alfred 4.2.1 [1187], Mac 11.0.1 (M1), 1Password 7 Version 7.7 (70700016).

Edited by jayhlee
Link to post

@jayhlee You have the box ticked for "Show in default results" so your bookmarks will only show in your default results. If you only want to see your bookmarks when typing "1p" first, then uncheck the "Show in default results".

 

What you're seeing is "1p" bringing up the 1Password app in your results. If you uncheck "Show in default results" then type "1p", you'll also see the "1Password Bookmark '...'" prompt, with the subtext "Find and open a 1Password 1Click Bookmark". See the second result in my screenshot.

 

Screenshot 2020-11-27 at 08.24.34.png

 

Cheers,
Vero

Link to post

Unfortunately I'm unable to log into websites directly from Alfred like I used to before when I typed in 1p followed by a space (see screenshot attached) and then the item name that sat within 1password. 

 

Is that no longer available in Big Sur?

 

 

Screen Shot 2020-11-28 at 10.48.10 am.png

Link to post

@AshR Could you please fill in your Powerpack email address in your forum profile first, as the 1Password feature is a Powerpack-specific feature?

 

Once you've done this, please provide the preferences details we asked for from the user above;

  • Your Features > 1PW prefs (feel free to crop out the content of your 1PW bookmarks, but let us know whether your bookmarks are showing correctly there) 
  • Exactly what you're typing into Alfred

Cheers,
Vero

Link to post
On 11/27/2020 at 12:23 AM, Vero said:

@jayhlee You have the box ticked for "Show in default results" so your bookmarks will only show in your default results. If you only want to see your bookmarks when typing "1p" first, then uncheck the "Show in default results".

 

What you're seeing is "1p" bringing up the 1Password app in your results. If you uncheck "Show in default results" then type "1p", you'll also see the "1Password Bookmark '...'" prompt, with the subtext "Find and open a 1Password 1Click Bookmark". See the second result in my screenshot.

 

Screenshot 2020-11-27 at 08.24.34.png

 

Cheers,
Vero

 

@Vero Thanks for the response. I actually had the box unticked before and it wasn't working. I'm not sure if this is the case, but I think it started to work either a) after I gave it some time to index my 1Password bookmarks, and/or b) after I disabled a few unit conversion workflows I downloaded that had results which took precedence over the "1p" results. But now, everything seems to be working fine, even after enabling the unit conversion workflows again (probably because I've been using 1P for 1Password a lot). Thanks again for your quick replies and help!

Link to post
  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...