Jump to content

Recommended Posts

@krusnof the first early beta of Big Sur was released only a few hours ago, I wouldn't recommend anybody installing it yet unless you absolutely HAVE to.

 

This is the first time we also have access to it, so we will be installing it and working towards getting Alfred prepared in due course.

 

Cheers,

Andrew

Link to post
Share on other sites
  • Andrew changed the title to Alfred on macOS Big Sur 11.0 beta

It does run, but there are some issues with certain features (I'll try to document and report the issues appropriately. It may well be user error in some cases). I'm sure Andrew and Vero will get all these things sorted out over the beta period! It is a beta period after all! 

 

 

UPDATE

AAAAAAND it was user error. Minor tweak to my AppleScript and it fixed it up. 

Edited by scottisloud
Link to post
Share on other sites
1 hour ago, scottisloud said:

AAAAAAND it was user error. Minor tweak to my AppleScript and it fixed it up. 

 

@scottisloud Glad it's working :) Any chance you could elaborate on what issue you saw / what fixed it? It may help other users who are playing with Big Sur for the first time. 

Link to post
Share on other sites
1 hour ago, srb1961 said:

Using Big Sur. When I invoke Alfred, it often jumps to a later item on the list of actions, and the "return"-executed (vs. command-numeral) option may be fourth or fifth on the list.

 

Where is your mouse when you're doing this? Could it be that your mouse is hovered over that result and Big Sur is treating it as selection?

 

Please say exactly which Big Sur build and Alfred version you're using to make this useful. :)

 

[Moving this thread to the Bugs section for Big Sur, as this is a beta.]

Link to post
Share on other sites
  • 2 weeks later...

Hi, and thanks; sorry for the delay; I forgot to check back here!

 

 I've since updated to Beta 2 of Big Sur. (11.0 Beta (20A4300b)), and it's still occurring.

My Alfred is 4.0.9 [1144]

 

Now that I've tested your suggestion, yes, it does indeed seem to occur--but only sometimes--when my cursor is in the Alfred pop-up area -- although I don't think this is behavior I've ever noticed before. Is it possible that it's somehow new? Or have I just never encountered it before?

 

 

 

Link to post
Share on other sites

@srb1961 You're using a Big Sur beta, which in itself is a huge unknown factor. However, if the mouse pointer is in Alfred's view and is moving imperceptibly, this would cause Alfred to highlight that row, regardless of OS version.

 

We'll be testing every feature on Big Sur thoroughly once it's a few beta builds in. From experience, the first few beta builds of a new macOS release evolve quickly (sometimes resolving bugs, sometimes introducing others), with significant changes in every update. Soon, we'll be doing our full testing, but at this time, it's essentially still a development build. :)  

Link to post
Share on other sites
  • 4 weeks later...

Biggest bug for me on Big Sur beta 3 (build 20A5323l) is that I'm unable to change the default shortcut from Opt+Space to Ctrl+Space. Clicking the field and hitting Ctrl+Space in Alfred Preferences does nothing. I even tried assigning a global "Toggle Alfred" shortcut in the Keyboard Shortcuts prefpane but no dice.

Link to post
Share on other sites

@killmoms This isn't going to be a bug - it'll be because the hotkey is reserved by something else on your Mac. Once you work out what feature or third-party app is reserving Ctrl + Space and you un-set it there, you'll be able to use it for Alfred if that's the combo you'd like to use.

 

Cheers,
Vero

Link to post
Share on other sites

In case nobody has found the solution yet, it's the language input switcher. If you go to System Preferences -> Keyboard -> Shortcuts, in the list on the left there should be "Input Sources". The shortcut you need to untick is in there.

 

If the "Input Sources" isn't shown on the left, then go to System Preferences -> Keyboard -> Input Sources (tab at the top) and add one, any will do. This will make the shortcut appear in the list now.

Link to post
Share on other sites
23 hours ago, fearoffish said:

In case nobody has found the solution yet, it's the language input switcher. If you go to System Preferences -> Keyboard -> Shortcuts, in the list on the left there should be "Input Sources". The shortcut you need to untick is in there.

 

If the "Input Sources" isn't shown on the left, then go to System Preferences -> Keyboard -> Input Sources (tab at the top) and add one, any will do. This will make the shortcut appear in the list now.

Thanks so much for this tip! I feel like I didn't have to do this on previous versions of macOS, but maybe it's that I did it so long ago I didn't remember I had to do it at one time.

Link to post
Share on other sites

One more side note, I think there's a bug where the shortcut still works for Input Sources in the background. So when you add that second Input Source, try and add a variant of what you already have. e.g. I added English - Extended ABC (or something like that), so if it switched it didn't matter. Before I did that, I was being switched to Coleman when I used ⌃-␣

Link to post
Share on other sites
  • 2 weeks later...

Final update, instead of just unticking the checkbox to disable the input source switcher...put a new keybind on them too. Something you'll never use like ⌘-⌃-⌥-F6

 

Doing this fixes that final and annoying "Why the hell has my input source switched again?" problem. Phew!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...