Jump to content

Dispatch Key Combo doesn't work for numpad keys [Fixed 4.5]


sub_o
 Share

Recommended Posts

Hi, I am using keyboard shortcut to control my Mission Control spaces,

e.g. Ctrl  + Cmd + Option + Numpad 7, etc.

But somehow when I am creating my workflow to dispatch the key combo, rather than triggering Numpad-7, it triggers the normal keychar of 7.

Is there a way to configure it so that I could send the signal as Numpad 7 instead (e.g. keycode 103 instead of keychar 7)

Thank you!

Link to comment
Share on other sites

@sub_o This is a side effect of Alfred being resilient in keyboard layouts which can change depending on the keyboard selected. Alfred keeps the character typed and looks up the code where relevant. Unfortunately, in your case, Alfred is looking up the top row numbers.

 

I'm going to treat this as a bug, as Alfred could really treat the numpad keys as special keys.  I'll move this thread into the bug forum, but it's not going to be fixed for 4.1 which is now code complete.

 

Cheers,

Andrew

Link to comment
Share on other sites

  • 5 months later...
  • 7 months later...

Numpad features have been added in Alfred 4.5, both recognising and dispatching numpad keys, and new popup menu options on the key combo editor for adding numpad keys on a Mac which doesn't have a numpad.

 

Let me know if you have any issues :) 

Link to comment
Share on other sites

  • Andrew changed the title to Dispatch Key Combo doesn't work for numpad keys [Fixed 4.5]
 Share

×
×
  • Create New...