Jump to content

[SOLVED] Alfred Workflow to Copy a Folder from Dropbox Location to Desktop


Recommended Posts

Hi. I'm looking to create an Alfred workflow that copies a template folder from its location in Dropbox to my Desktop. The folder path to be copied is follows:

/Users/aaronriddle/Dropbox (Personal)/Aaron Riddle Photography/Video/Virginia Elope Video Template

I want to copy it to my Desktop path as follows:

/Users/aaronriddle/Desktop

I tried doing this via terminal using the below script:

 cp -a /Users/aaronriddle/Dropbox (Personal)/Aaron Riddle Photography/Video/Virginia Elope Video Template. /Users/aaronriddle/Desktop/

However, it gives me the following error:  

zsh: no matches found: (Personal)/Aaron

Can someone point out what is wrong with the terminal script, OR suggest if there is a better way to do this? 

 

Thank you for your help!

Link to post
2 hours ago, afordturtle said:

Can someone point out what is wrong with the terminal script

 

When you do cp -a /Users/, the shell knows that cp, -a, and /Users are different arguments because they have spaces between them. So how is the shell supposed to know that Dropbox (Personal) is part of the same argument, and not Dropbox and (Personal)?

 

The answer is quoting:

 cp -a '/Users/aaronriddle/Dropbox (Personal)/Aaron Riddle Photography/Video/Virginia Elope Video Template' '/Users/aaronriddle/Desktop/'

 

Link to post
  • vitor changed the title to [SOLVED] Alfred Workflow to Copy a Folder from Dropbox Location to Desktop

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...