Jump to content

Spelling suggestions


Recommended Posts

Hi! 

Is there a way to have spell keyword work with more than one language? 

Right now if I set Language in Dictionary section of Alfred settings to default or English then I can misspell the word in English and it will suggest the closest match with proper spelling. If I change the keyboard input to Russian and misspell the word, then it'll tell me "Not Found'. 

If I set Language in Dictionary section of Alfred settings to Russian, then it will find the closest match to misspelled word in Russian, but will tell me 'Not Found' if I misspell the word in English. 

 

So can I have Alfred suggest correct spelling both in English and Russian? 

Link to post
8 hours ago, RuslanI said:

So can I have Alfred suggest correct spelling both in English and Russian?

 

What exactly are you asking here? Keyboard layout and language are two separate, largely unrelated settings. You say you switch keyboard layouts, but do you actually mean "write in a different language"?

 

I mean, is the problem that "приве́т" isn't found because the dictionary is set to English, or that "privet" isn't found when the dictionary is set to Russian?

Edited by deanishe
Link to post
35 minutes ago, deanishe said:

What exactly are you asking here?

 

I think it’s so Alfred’s spell keyword works with two languages at once without having to be explicit which is being used, like iOS does now.

Link to post
2 hours ago, vitor said:

without having to be explicit which is being used, like iOS does now.

 

I guess that would work well with Russian and English.

 

But iOS drives me nuts with this. German and English are apparently too similar, and it constantly suggests words from the wrong language for me.

Link to post
  • 3 months later...
On 7/21/2020 at 12:44 AM, vitor said:

 

I think it’s so Alfred’s spell keyword works with two languages at once without having to be explicit which is being used, like iOS does now.

Yes, exactly! 

Right now the Language in Alfred Settings -> Features -> Dictionary is set to Russian, so:

1550115849_ScreenShot2020-11-17at00_15_03.thumb.png.002f39730bbddc568e98ceffaa5b8480.png

 

Which is what I want. But without changing the Dictionary Language to anything else:

 

1733189418_ScreenShot2020-11-17at00_16_29.thumb.png.ff0ba4e0f7284a6d4750b740f7f1353c.png

 

So if I want the 'spell hous' to autosuggest 'house'  I have to change the Dictionary setting to English. But then the Russian autosuggest stops working. 

 

Edited by RuslanI
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...