Jump to content

"The workflow you are trying to import is invalid..."

Recommended Posts

New to Alfred and trying to create a simple workflow for adding a task to Mac's "Reminders" app. I haven't found any good tutorials explaining how to do this from scratch, and all the pre-made workflows I've tried downloading result in the error listed in the image below. I'd like to build something similar to Jono Hunt's Reminders workflow (listed on Alfred's featured workflow for Fantastical 2) but to upload directly to an "Inbox" reminders list... Any solutions?

Screen Shot 2020-08-14 at 12.04.04 PM.png

Link to comment

@rascalroots Thanks for filling in your Powerpack details.


Could you please provide more information?


- Which version of Alfred are you using?

- Which version of macOS?

- Have you tried re-downloading the workflow in case your download was corrupted the first time?


I've imported this workflow into Alfred 4 with no error message, so please provide more details as to your specific scenario :)



Link to comment

@rascalroots In your video, I can see that you're not straight downloading the workflow file, you're opening it with archive utility, which is changing what you've downloaded.


In the Firefox popup, select "Save File" instead, and save it to your desktop, then you'll get the actual workflow file with a .alfredworkflow extension, and an Alfred icon. This should import into Alfred just fine.


Also, try downloading and installing one of our workflows to make sure there isn't something installed on your Mac which is interfering with Alfred's file type (as it conforms to public.zip-archive so 3rd party unarchiving utilities can break things). There is a simple workflow you could try here:






Link to comment
9 hours ago, Andrew said:

In your video, I can see that you're not straight downloading the workflow file, you're opening it with archive utility


The download is a zip file, with an .alfredworkflow file inside it (along with some other stuff). The workflow's fine, though.


1 hour ago, rascalroots said:

Looks like there is some sort of interference, but I don't have any 3rd party unarchiving utilities downloaded.


Are you running antivirus software?

Link to comment

I'm running into the same issue, sort of. I download the flip workflow, unarchive it but archive it back, and it cannot open the workflow anymore. The reason I'm unarchiving and archiving it back is to see if this problem is just with my package or something else. I remember this working before - I'd take a folder, archive it, rename it to foo.alfredworkflow, double click it and it would work, not anymore. What changed?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...