Jump to content

Help with finding files


Recommended Posts

I am running latest macOS Big Sur and I believe with recent build this issue started occuring. I have a workflow to search markdown files in a folder. Looks like this:

 

image.png.3e49597f290ab748795954c990fc9763.png

 

image.png.eec7af2feacf38004c5c48e3345f095e.png

 

image.png.3cd02b978e48c87b13ad07e72aee8ff4.png

 

There are some files that it should return but doesn't. For example this file:

 

image.png.2fa5c44b0649a60da1aabeed3959d63c.png

 

Is not returned:

 

image.thumb.png.8cf33634441dd4d5cdccca4e8eab87c2.png

 

Some other files are. Sometimes they do come back, sometimes they are no longer there. 

 

 

Link to post

The workflow is manage notes in here for reference. Perhaps I should run a reindexer but it's weird that `'` search returns results but the scoped things has buggy behavior. I assume that since the file is found through the all file search, the spotlight index is fine and something is off with Alfred?

The workflow worked flawlessly before this recent Big Sur beta build. 

Link to post

@nikivi Ensuring you're using Alfred 4.1.1, go to Alfred's preferences > Help > Troubleshooting and run the File Search Troubleshooting, dragging in some of the files you are expecting to see in your File Filter.

 

This will give you more information on whether the metadata for these files is complete, and if their file type matches what you've included in your File Filter.

 

Cheers,
Vero

Link to post
Posted (edited)
7 hours ago, dfay said:

have you tried rebuilding launch services so markdown files get the correct uti assigned?


Last time I tried to look into it, I got stuck and didn't want to ask further questions. Will try again.

Edited by nikivi
Link to post
  • Andrew changed the title to Help with finding files

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...