Jump to content

My own contact no longer found with new Alfred version: 4.2


Recommended Posts

@nikivi I'm sure you've been using Alfred for long enough to appreciate that Alfred didn't just turn around one morning and decide he didn't feel like returning your contact. :)

 

This will be down to the data being provided by macOS...

 

Some useful information you could provide when reporting this:

- Which version of macOS are you using?

- Are your contacts set to use the default method, or did you check the "Use Spotlight metadata for searching contacts" under Features > Contacts > Advanced?

- Is Spotlight finding your contact?

- If you make a small modification to your contact in the Contacts app, does it reappear in results?

 

The more information you can provide, the more likely we'll be able to help you out.

 

Cheers,
Vero

 

Link to post
Share on other sites

1. Version of macOS: 11.0.1 Beta

2. Didn't set it

 

image.thumb.png.82e0591af7c2b5ca8260295a77a590d6.png

 

3. Actually it appears my Spotlight is broken fully, whatever I search, returns only this:

 

image.thumb.png.a69eb9bcd41ead4543cf3071695d9140.png

4. Tried that, no change, the contact still doesn't show.

 

I assume since the answer to question 2 is that I selected for Alfred to not use the Spotlight for searching contacts, there is not going to be any point in rebuilding spotlight index? I am going to try it anyway I suppose. It could also be that Alfred method of getting current contact on latest macOS Big Sur beta version is no longer working correctly.

 

Thank you for any help.

Link to post
Share on other sites

@nikivi I'm moving this to the Big Sur Beta section, which is where this originally should have been posted.

 

To my knowledge, we haven't seen any issues with contacts in Big Sur, but by putting it in the appropriate forum section, other users will be able to confirm either way.

 

In the meantime, yes, it does look like your Spotlight is having some issues...

Link to post
Share on other sites

Okay I found what the bug is. If the contact has any note attached, the contact will no longer appear to be searched with Alfred.

 

Before:

 

image.thumb.png.8192d71c2f890e1cee7bf2942c2fc035.png

 

With note added:

 

 718968080_ScreenShot2020-11-05at14_41_01.thumb.png.68365157f8f96c3dafc0616ac54a52b4.png

 

Can replicate it 100 % of times.

Link to post
Share on other sites

@nikivi I'm currently using Big Sur 11.0.1 Release Candidate 20B5022a and what you describe is working as expected.

 

I notice your screenshot has the contacts icon to the right had side, this suggests you're using a workflow? If your workflow is using a File Filter for Contacts this likely won't work as your Spotlight index looks very broken.

 

Have you tried searching for contacts in Alfred's default results?

 

NOTE: For searching in the default results, ensure you have the following settings in Alfred for Big Sur:

  1. Contact searching ENABLED in default results in Alfred's Features > Default Results.
  2. "Use Spotlight metadata for searching contacts" DISABLED in Alfred's Features > Contacts, as per your screenshot above.

Other than this, if your Spotlight is broken as much as you show, it might be worth reinstalling Big Sur.

 

Cheers,

Andrew

Link to post
Share on other sites
6 minutes ago, Andrew said:

Have you tried searching for contacts in Alfred's default results

 

That works. Although I prefer to use my file filter.

Will try reinstall Big Sur when the public release is out. Thank you lots. 💚

Link to post
Share on other sites
  • 2 weeks later...

@Andrew I'm going to piggy back on this thread because I think it might be related to something I just discovered... 


I'm also on Big Sur 11.0.1 + Alfred 4.2.1-1187

 

After the "upgrade" 😞  to BigSur, my contact searches started turning up empty. I checked to make sure the metadata files were there on the disk (yep) and were readable, etc. Here's how my contacts search is set (using a custom "file filter" search)

image.png.74743d6ff212578dd3c4edd76939fb76.png

image.png.075461e3047caa0ae78c88a9b546f14f.png

 

I finally tried enabling the "Show files marked as System File" checkbox... and voilà, everything was right again. 

 

A further check revealed that macOS had decided to mark all of the contact metadata (.ABCDP files) as "system files":

 

$ mdls -name kMDItemSupportFileType 0A6EF4A4-F197-4E58-89B1-3289AA2C418D\:ABPerson.abcdp
kMDItemSupportFileType = (
    MDSystemFile
)

 

No amount of "sudo xattr -d com.apple.metadata:kMDItemSupportFileType" etc worked for me to try to remove that flag. I don't know if it's possible, but for now the only working fix for me is to enable the "Show files marked as System File" checkbox in my workflow.

Link to post
Share on other sites
2 hours ago, luckman212 said:

I finally tried enabling the "Show files marked as System File" checkbox... and voilà, everything was right again.


Beautiful. Thank you so much for finding this. Works for me too now. ♥️

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...