Jump to content

Alfred searches are incomplete

Recommended Posts

After upgrading to Big Sur, alfred has returned incomplete searches even though the folders and files can be found in spotlight.  I've reindexed a few times already and added and removed the main folder where the missing subfolders are found but alfred still does not return the search



Screen Shot 2020-11-17 at 10.28.12 AM.png

Screen Shot 2020-11-17 at 10.28.03 AM.png

Edited by 34celtics
Link to comment

@34celtics If you've installed Alfred in the same breath as Big Sur, remember that macOS needs a little time to get itself fully indexed. This means that the macOS metadata index that provides results to Alfred may take a few minutes (or hours) to complete. Make sure you're using Alfred 4.2.1 as well.

If it's been a little while since your install, you can also use Alfred's built-in File Troubleshooting tool, which you'll find in the Preferences > Help > Troubleshooting > Run Troubleshooting. Drag in a few files from Finder that you're unable to locate in Alfred, and you'll be guided through resolving the issue.


If you need further help, please provide the output from the File Troubleshooting.


Also, please let us know whether you've installed Big Sur fresh or upgraded from either Catalina or the Big Sur betas. 



Link to comment

Hi Vero,


I upgraded from Catalina.  I'm not sure if the size of the main folder is an issue but it has about 2,200 subfolders in it, with each subfolder having about 10 to 20 files each.  What I discovered is a subfolder missing in Alfred will start to show up in Alfred after I open the subfolder.  But, I still won't be able to find the contents of that subfolder unless I open the files in the subfolder.


Here's a diagnostic output of a folder before I opened it.


Starting Diagnostics...

File: '1902748 8-Story Resort Cabangan'
Path: '/Users/brain/Documents/Consulting'


Check file cache database...

File cache integrity is ok


Check if file is readable...

Alfred has permissions to read this file.


Check file is in search scope...

File exists within Alfred's default search scope


Check if volume '/' is indexed by macOS...

Indexing is enabled on this drive


Check direct file metadata...

Direct metadata available

Display Name: 1902748 8-Story Resort Cabangan
 Other Names: 
Content Type: public.folder
   Last Used: 


Check mdls file metadata...

Metadata contains required items

_kMDItemDisplayNameWithExtensions      = "1902748 8-Story Resort Cabangan"
kMDItemContentCreationDate             = 2019-12-02 01:24:42 +0000
kMDItemContentCreationDate_Ranking     = 2019-12-02 00:00:00 +0000
kMDItemContentModificationDate         = 2020-01-06 07:56:30 +0000
kMDItemContentModificationDate_Ranking = 2020-01-06 00:00:00 +0000
kMDItemContentType                     = "public.folder"
kMDItemContentTypeTree                 = (
kMDItemDateAdded                       = 2019-12-02 01:24:42 +0000
kMDItemDateAdded_Ranking               = 2019-12-02 00:00:00 +0000
kMDItemDisplayName                     = "1902748 8-Story Resort Cabangan"
kMDItemDocumentIdentifier              = 0
kMDItemFSContentChangeDate             = 2020-01-06 07:56:30 +0000
kMDItemFSCreationDate                  = 2019-12-02 01:24:42 +0000
kMDItemFSCreatorCode                   = ""
kMDItemFSFinderFlags                   = 0
kMDItemFSHasCustomIcon                 = (null)
kMDItemFSInvisible                     = 0
kMDItemFSIsExtensionHidden             = 0
kMDItemFSIsStationery                  = (null)
kMDItemFSLabel                         = 0
kMDItemFSName                          = "1902748 8-Story Resort Cabangan"
kMDItemFSNodeCount                     = 15
kMDItemFSOwnerGroupID                  = 20
kMDItemFSOwnerUserID                   = 501
kMDItemFSSize                          = (null)
kMDItemFSTypeCode                      = ""
kMDItemInterestingDate_Ranking         = 2020-01-06 00:00:00 +0000
kMDItemKind                            = "Folder"


Troubleshooting passed




After I opened the folder and it started showing up on Alfred, these lines got changed or added at the end of the diagnostics:



kMDItemInterestingDate_Ranking         = 2020-11-17 00:00:00 +0000
kMDItemKind                            = "Folder"
kMDItemLastUsedDate                    = 2020-11-17 09:59:16 +0000
kMDItemLastUsedDate_Ranking            = 2020-11-17 00:00:00 +0000
kMDItemUseCount                        = 1
kMDItemUsedDates                       = (
    "2020-11-16 16:00:00 +0000"

Link to comment

@34celtics If results are sometimes showing in Alfred and sometimes not, and you haven't tweaked your preferences in between, it's a sign that macOS isn't returning the full results to Alfred at all times. Are these files all on your local drive and not in cloud-based locations or external drives?


There have only been a few users reporting issues with their index upon upgrade, and one has already let us know that he did a fresh Big Sur install, which fixed his indexing issues (as well as resolving a few other non-indexing, non-Alfred related issues that appeared to be a hangup from the upgrade from Catalina). I appreciate that suggesting a clean install of an OS is a bit more of an undertaking, but you'll likely find that it resolves the index unpredictability you're seeing.




Link to comment

I have had a very similar issue, with a similar resolution:

  • projects folder with 3 subfolders: pnl, tpl, wrk
  • wrk and tpl can be reached with Alfred using the ' shortcut. 
  • pnl can't.


pnl passes the "troubleshooting" step with all green checkmarks

pnl can be reached by navigating from ~/Documents ... in Alfred


moving pnl out of projects and into ~/Documents solves the issue. 

moving pnl back into projects, issue stays solved ...


I don't know how to check if spotlignt has indexed the files or not, but for the record, this was an upgrade from Catalina on day 2 of Big Sur availability, with Alfred already installed for a long time before that. the projects, pnl, tpl and wrk structure however was brand new.


Link to comment
44 minutes ago, seishonagon said:

I don't know how to check if spotlignt has indexed the files or not,


Try to find it in Spotlight.


58 minutes ago, seishonagon said:
  • projects folder with 3 subfolders: pnl, tpl, wrk
  • wrk and tpl can be reached with Alfred using the ' shortcut. 
  • pnl can't.


What do you mean "pnl can't"? What do you see when you search for "pnl"? Are there lots of other results, just not that folder?

Link to comment

@VeroJust an update to my previous message...I thought I had it solved but the problem came back after I shut down my computer.  I tried moving all the contents of that one  folder into another renamed folder and individually reindexing each folder, but neither solution worked.


What finally solved the problem was reducing the number of folders directly in that folder (I had about 2000+ folders in that one folder).  So I made five folders and divided the 2000+ folders between the five folders.  After that, it worked perfectly even after multiple reboots. 


FYI, I could still find items in Spotlight even when all the folders were just in one folder.  And so I'm not sure if the problem was the way Alfred got the information from spotlight or if it has to do with the handling of the info from a folder with a lot of files.


Anyway, I just put this here in case someone encounters the same problem.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...