Jump to content

Alfred issue after rebooting in Big Sur


Philip_D

Recommended Posts

First time after update it worked well, but after reboot it stopped working. It's listed in Activity Monitor, but hotkey not working and there's no icon in the status bar. I tried removing folder from Application support - after launch there're initial steps like license, migration, etc, but after they pass - it doesn't work the same way as at the beginning.

Here's console log, filtered with `Alfred`: https://gist.github.com/PhilipDukhov/746b4c55b7e8cc763d67d1787942509e

 

P.S. funny detail - clipboard history shortcut works, but the history is empty; append clipboard shortcut doesn't work

Edited by Philip_D
Link to post
  • Andrew changed the title to Alfred issue after rebooting in Big Sur

@Philip_D I would recommend following the same steps as provided to these users: 

It's likely a permissions issue due to the upgrade to Big Sur so the steps outlined there should resolve things for you.

 

Let us know how you get on, as it may be useful for others who come across this thread.

 

Cheers,
Vero

 

Link to post

@Philip_D Are you running any third-party "app cleaners" that could be interfering with Alfred's normal operation by removing essential files? 

 

When you say the hotkey isn't working, is Alfred running in Activity Monitor? What is your hotkey set to? Have you checked whether Spotlight or another app is using the same hotkey? For example, if you change your Alfred hotkey to something more obscure that isn't used by a third-party, does Alfred show as expected?

 

If you can be more specific/detailed in describing the problem you're seeing, I'll be able to help you more accurately.

 

Cheers,
Vero

Link to post

I don't user any app cleaners. I have Alfred on cmd-space, and spotlight shortcut is off. Yes, it was shown in the Activity Monitor, but not reacting on the main shortcut. I was removing permissions in next order: Full disk access -> Accessibility -> Contacts, and each time was trying to start Alfred after force quitting it, and only after Contacts access removed it started working again

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...