Jump to content

Alfred 2: problem with Spotlight comments [Fixed in temp b180, link in thread]


shadylane
 Share

Recommended Posts

Hi,

 

I finally came around to installing Alfred 2 (version 2.0.2 178, to be specific) and everything seemed to work perfectly - I had no problems with import and setup and version 2 looks absolutely awesome! But it didn't take long until I encountered a weird issue with Spotlight comments. I have always used Spotlight comments with Alfred and pretty much all my folders and applications have at least one comment. But Alfred 2 doesn't find any folder / app when I search for Spotlight comments and instead shows the following messages in Console.app:

 

27.03.13 13:36:24,143 Alfred 2[198]: -[__NSCFString count]: unrecognized selector sent to instance 0x104c6c230

27.03.13 13:36:24,143 Alfred 2[198]: -[__NSCFString count]: unrecognized selector sent to instance 0x104c6c230

27.03.13 13:36:24,174 Alfred 2[198]: (

    0   CoreFoundation                      0x00007fff86e78b06 __exceptionPreprocess + 198

    1   libobjc.A.dylib                     0x00007fff8ef5d3f0 objc_exception_throw + 43

    2   CoreFoundation                      0x00007fff86f0f40a -[NSObject(NSObject) doesNotRecognizeSelector:] + 186

    3   CoreFoundation                      0x00007fff86e6702e ___forwarding___ + 414

    4   CoreFoundation                      0x00007fff86e66e18 _CF_forwarding_prep_0 + 232

    5   Alfred Framework                    0x00000001000e185d -[AlfredSystemWorkflowFileCache joinComments:andKeywords:] + 154

    6   Alfred Framework                    0x00000001000e1b54 -[AlfredSystemWorkflowFileCache updateCache:] + 540

    7   Alfred Framework                    0x00000001000d0bbf -[AlfredWorkflowInputFileFilter rebuildResults] + 1316

    8   Alfred Framework                    0x00000001000d03a9 -[AlfredWorkflowInputFileFilter metadataQuerierUpdated:] + 29

    9   CoreFoundation                      0x00007fff86e2aeda _CFXNotificationPost + 2554

    10  Foundation                          0x00007fff88dcde26 -[NSNotificationCenter postNotificationName:object:userInfo:] + 64

    11  Alfred Framework                    0x00000001000bf916 -[AlfredMetadataQuerier updateResults] + 2763

    12  CoreFoundation                      0x00007fff86e2aeda _CFXNotificationPost + 2554

    13  CoreFoundation                      0x00007fff86e5bb5e CFNotificationCenterPostNotificationWithOptions + 110

    14  Metadata                            0x00007fff9036c94e ___pushNotification_block_invoke_0 + 97

    15  CoreFoundation                      0x00007fff86e35cd2 __CFRUNLOOP_IS_CALLING_OUT_TO_A_BLOCK__ + 18

    16  CoreFoundation                      0x00007fff86df647f __CFRunLoopDoBlocks + 255

    17  CoreFoundation                      0x00007fff86e1ac7c __CFRunLoopRun + 1948

    18  CoreFoundation                      0x00007fff86e1a0e2 CFRunLoopRunSpecific + 290

    19  HIToolbox                           0x00007fff8702feb4 RunCurrentEventLoopInMode + 209

    20  HIToolbox                           0x00007fff8702fc52 ReceiveNextEventCommon + 356

    21  HIToolbox                           0x00007fff8702fae3 BlockUntilNextEventMatchingListInMode + 62

    22  AppKit                              0x00007fff90ad6563 _DPSNextEvent + 685

    23  AppKit                              0x00007fff90ad5e22 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128

    24  AppKit                              0x00007fff90acd1d3 -[NSApplication run] + 517

    25  AppKit                              0x00007fff90a71c06 NSApplicationMain + 869

    26  Alfred 2                            0x000000010000163c Alfred 2 + 5692

    27  ???                                 0x0000000000000002 0x0 + 2

)

 

When I try to search for another comment, the same messages appear in console - no matter what comment I search for, Alfred 2 doesn't find the item and instead logs those messages.

 

The weird thing is: Spotlight itself and Alfred 1 have no problems with my Spotlight comments, both of them find the specific app or folder instantly. Very weird.

I tried restarting my iMac several times, I re-installed Alfred 2, I rebuild the Spotlight index, I basically tried all the steps on the "Why isn't Alfred finding the file I'm looking for" support-page, but no luck.

I would really appreciate any advice, I don't know what else to try...

 

Mac OS X 10.8.3, 2011 iMac, Alfred Version 2.0.2 178;

Reproducable: yes, whenever I search for a Spotlight comment;
Link to comment
Share on other sites

Hi,
 
Mac OS X 10.8.3, 2011 iMac, Alfred Version 2.0.2 178;
Reproducable: yes, whenever I search for a Spotlight comment;

 

Very interesting indeed! I can see where this might be happening in code, but am unable to reproduce the issue. Could you please pop an email to info@alfredapp com so I can send you a build which may fix this issue for you? :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...