Jump to content

Hotkey trigger doesn't output macOS selection


Recommended Posts

OK, it seems that the problem is in my setup. I killed all the other apps and it started working. I think some other app started acting up a bit differently after upgrade to Big Sur.

 

Sorry to bother you, I guess the issue can be closed. 

 

I'll look into that and maybe will post what app caused that, so that other people bumping into that will see it.

Link to comment
Share on other sites

The app causing that was TickTick, because my shortcut (Cmd+Shift+O) seemed to coincide with its default global one (and by strange coincidence, the other shortcut I used for testing, Cmd+Option+Cmd+Z, coincided as well).

 

Thank you again for quick response and have a nice day! 

Edited by everyonesdesign
Link to comment
Share on other sites

  • 1 month later...

I met the similar situation

image.thumb.png.b16ac4bd9b107ee747124a4a33c525fb.png

url="{query}"
if [[ ${url:0:7} == "http://" || ${url:0:8} == "https://"  || ${url:0:4} == "www." ]] 
then
	open $url
else
    open https://www.google.com/search?q="$url"
fi

It was fine on MacOS 10.15 before, but this hotkey disabled frequently after updating to 11.1

 

And the hotkey disabled for two scenes:

1. delay to open the urlimage.thumb.png.bcc85be02d14e09dce52914ea7363701.png

2. occur an error which is like (open /usr/****/https://www.google.com/search?q='$url') and I forgot save a screenshot. (I will upload it when this situation happens next time)

Link to comment
Share on other sites

I'm still experiencing this issue today on macOS 10.15.7 (19H15), with Alfred 4.3 Build 1205 (Monday 14th December 2020).

I have no language inputs enabled on my system other than English (QWERTY), so I don't think it's an issue specific to users with Pinyin input enabled.

My workflow to reproduce the issue is in the screenshot below (inside the Large Type action is just `{query}`). It never triggers however because query is always empty.

If I change it to `{query} abcd` it triggers but shows only `abcd` in large type, confirming that the key command is working fine, it's just the pass "Selection in macOS" that's failing to grab text from the active application.

I've already tried removing all of Alfred's permissions in System Preferences and re-enabling, as well as restarting Alfred and the computer altogether. Nothing seems to fix it, "Selection in macOS" is always empty regardless of which foreground app I try triggering the workflow from.

 

image.thumb.png.d55bd2995d0969fef54e7c5f9c1643ce.png

Link to comment
Share on other sites

@theSquashSH Alfred needs to be able to simulate ⌘C to get the selection in macOS, so there must be something which is stopping this from happening.

 

Could you first try the lock command in Alfred, which simulates the macOS ⌃⌘Q shortcut and see if this works?

Link to comment
Share on other sites

  • 4 months later...

I was having an issue where selection hot key wasn't working. Finally realized it just doesn't work for video files (e.g., mov, m4v). Maybe Alfred update can fix this?

Link to comment
Share on other sites

Posted (edited)

@Andrew sorry for the tremendously late reply.

I can confirm the issue is still happening in the latest version (Alfred 4.3.4 on macOS 11.2.3).

Several Alfred features that require simulating key commands don't work, including "Show Large Type" and some of my workflows. 

I just tested the Lock command in Alfred and it didn't work either, so something seems to be preventing it from simulating key events in general.

I have all permissions checked for Alfred under System Preferences > Security > *, so I don't think it's that.

Any ideas?

image.thumb.png.34390cf5de4f5e57cabb46fd82576301.png
(and the others ^, e.g. Files and Folders, Automation, etc. are all checked as well)

Thanks for the help!

Edited by theSquashSH
Link to comment
Share on other sites

2 hours ago, theSquashSH said:

Several Alfred features that require simulating key commands don't work, including "Show Large Type" and some of my workflows. 

 

Could you please open the Accessibility preferences, remove Alfred using the minus symbol, then re-add Alfred to the Accessibility list? Based on what you're describing, it seems that macOS has forgotten the permissions, so re-setting them should resolve that.

 

Let me know how you get on :)

 

Cheers,
Vero

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...