Jump to content

Snippets don't work when Secure Entry is locked by iTerm


Recommended Posts

Snippet function worked couples of days ago (4.2.0), this issue very possible due to new version released (4.2.1 in 13th November)

 

Mac Version:

 

$ sw_vers
ProductName: macOS
ProductVersion: 11.0.1
BuildVersion: 20B29

 

Alfred Version:

Alfred 4.2.1 [1187]

 

Permission check:

image.thumb.png.830695be2742f21aba3f43644eecaacc.png

 

Example:

image.png.f6fb4812afac88a85d78670e1bec6853.png

 

Result:

https://github.com/marslo/marslo-test/blob/issues/screenshots/alfred/snippets-not-work-mac-11.0.1.gif (upload limitation for accessory size)

Link to post
Share on other sites

@marslo As per the error message in red in your clip, iTerm 2 has taken secure input. While this error is showing, no apps can expand snippets, as iTerm 2 is restricting other apps from seeing your keypresses, and therefore from being able to expand snippets.

 

Quit iTerm and keep an eye out for errors such as the one shown in your clip.

 

More on secure entry here:

https://www.alfredapp.com/help/troubleshooting/snippets/#secure-input

 

Cheers,
Vero

Link to post
Share on other sites
  • Vero changed the title to Snippets don't work when Secure Entry is locked by iTerm

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...