Jump to content

[Solved] Granting accessibility for snippets on M1 Mac Mini


tdenson

Recommended Posts

I've just migrated my Alfred settings to an M1 Mac and everything is OK apart from snippets not working. I have enabled accessibility as required but still no joy. Anything else I am missing ?

Edited by Vero
Edited title to be more specific
Link to post

@tdenson We've also been testing Alfred in Big Sur on an M1 Mac, and it's working as expected, so it's likely your issue is more of a permissions one. :)

 

- Which version of Alfred are you using?
- Have you granted Alfred all necessary permissions? https://www.alfredapp.com/help/getting-started/permissions/ (Try removing Alfred 4 altogether and re-adding, in case there's any corruption of permissions in macOS)
- Are snippets enabled in Alfred's preferences?
- Is the specific snippet you're trying to use enabled for expansion?
- When you try to expand a snippet, at what stage does it fail? E.g. Does the snippet disappear and nothing is pasted, or does the snippet keyword not disappear either?
- Does the issue occur in all apps or only some apps? Test in TextEdit, which is one of the simplest apps, as some more complex apps or browsers have their own clipboard management or behaviours that may cause issues
- Do you use any third-party clipboard managers or snippets tools that may be interfering?

 

Cheers,
Vero

Link to post
2 hours ago, Vero said:

@tdenson We've also been testing Alfred in Big Sur on an M1 Mac, and it's working as expected, so it's likely your issue is more of a permissions one. :)

 

- Which version of Alfred are you using?

4.2.1 Universal (1186)


- Have you granted Alfred all necessary permissions? https://www.alfredapp.com/help/getting-started/permissions/ (Try removing Alfred 4 altogether and re-adding, in case there's any corruption of permissions in macOS)

Yes and I have uninstalled and reinstalled Alfred. Although there is a strange thing with Mac Preferences. I cannot untick Alfred in the Accessibility option (I was trying to toggle it)


- Are snippets enabled in Alfred's preferences?

Yes, and they worked on the machine I have migrated from and whose preferences I have imported via DropBox


- Is the specific snippet you're trying to use enabled for expansion?

Yes


- When you try to expand a snippet, at what stage does it fail? E.g. Does the snippet disappear and nothing is pasted, or does the snippet keyword not disappear either?

It echos the keyword such as `e - I use ` for snippets.


- Does the issue occur in all apps or only some apps? Test in TextEdit, which is one of the simplest apps, as some more complex apps or browsers have their own clipboard management or behaviours that may cause issues

True in all apps, as it happens I always use Textedit for testing


- Do you use any third-party clipboard managers or snippets tools that may be interfering?

No

 

And BTW all my other imported features such as workflows are working.

 

Link to post
3 minutes ago, tdenson said:

Yes and I have uninstalled and reinstalled Alfred. Although there is a strange thing with Mac Preferences. I cannot untick Alfred in the Accessibility option (I was trying to toggle it)

 

Un-toggling and re-toggling won't have any effect. As I said, you need to remove and re-add Alfred by following these steps:

 

- Quit Alfred 4

- Go to System Preferences > Security & Privacy > Accessibility

- Ensure the padlock in the bottom left is unlocked and you've authenticated with your password

- Select Alfred 4, then click the minus button

- Either use the + button to re-add Alfred 4 to the list

- Relaunch Alfred 4

 

Cheers,
Vero

Link to post
  • Vero changed the title to [Solved] Granting accessibility for snippets on M1 Mac Mini

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...