Jump to content

option to disable system text replacement


Alan He
 Share

Recommended Posts

I have setting system text replacement, like qq. system will replace with number 123456789.

 

I hava setting a workflow and key word set as qq. when I trigger with qq in alfred's input , text will replace,It's very inconvenient unless I click esc.

 

So I hope alfred can support option to disable system text replacement

 

 

 

First of all, the reason for using system text replacement is that it does not require some prefixes, which is more convenient

 

image.thumb.png.944521883d831ba27ef2fed65b12e2f9.png

 

image.thumb.png.ba56ae5b46dc66976a8cf96d4672392e.png

Edited by Alan He
Link to comment
Share on other sites

@Alan He Alfred can't override macOS's own text expansion, so your best bet is to change your macOS text expansion to something less likely to be accidentally triggered (e.g. replace "qq" with "!qq" with an exclamation mark prefix), or disable it altogether as you can create these as snippets in Alfred.

 

Cheers,
Vero

Link to comment
Share on other sites

Understand what you mean, then this is the only way.

The reason why system text replacement is still needed is that I need to consider the support on iOS for some texts, so that it can be used across multiple types of devices.

Therefore, the system level and Alfred's Snippet are complementary to a certain extent to solve text replacement

Link to comment
Share on other sites

  • 6 months later...

Same issue here!! I set up a lot of short texts, so it's very annoying for me.

 

In other Apps, like Google Chrome for example, go to the menu bar and choose "Edit > Substitutions > Show Substitutions > Text Replacement" and deselect Text Replacement. This could turn off the text replacement feature.

 

But, there' no menu bar show with alfred's input box!

I can find the same menu with mouse right click on it, and can be disable temporary, but it won't save! Text replacement will re-enable after reboot.

Can't find a solution....

Link to comment
Share on other sites

52 minutes ago, xforce said:

Text replacement will re-enable after reboot.

 

I didn't know that.

 

There must be some setting we can change with defaults.

 

EDIT: Nope. It seems it's up to every application to implement persistence itself. Forgetting your changes when you quit the app is the default behaviour.

 

As a sort of workaround, you could use my script to export your macOS text replacements to Alfred snippets. Then you can turn off text replacements globally, but still use them cross-platform, and let Alfred manage which apps they are and aren't expanded in.

Edited by deanishe
Link to comment
Share on other sites

1 hour ago, deanishe said:

Then you can turn off text replacements globally

 

Thanks @deanishe

 

I couldn't find a way to turn off text replacements globally. Could you tell me how?

 

I searched a post about this:
https://apple.stackexchange.com/questions/231336/how-can-i-globally-disable-text-replacement

 

Tried, but no luck. The command seems not working. I'm using macOS Big Sur.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...