Jump to content

Issue with my contact metadata


nikivi

Recommended Posts

Get this when trying to search contacts:

 

image.thumb.png.c9d1700805a63b8a547360fb30555aea.png

 

I reset Spotlight index and had it finish doing the indexing. Not sure what else I need to do.

 

My situation is that my macOS got broken on latest Big Sur update. Had to restore from backup. And now I get this.

 

Might be included to this but my file filter searches are also broke now. This file in ~/Dropbox/Write/knowledge:

 

image.png.e352233db9ec5bc4353d1c7a9e7b9bb9.png

Is no longer being found using my file filter workflow that searches this folder for markdown files:

 

image.png.7836aa98fab2a51dd3370463a2850141.png

 

image.png.ce491c85108cd97e508d3d0af316d6b5.png
 

 

image.png.3a054d645128861efda996b7b735b45e.png

 

I no longer have the Alfred Meta viewer app but I did drop the file again into the File Types section and it is recognized by Alfred as .markdown just no results are returned for any markdown file using the file filter.

 

 

 

 

 

Edited by nikivi
Link to post

[Original reply from when this was posted as a Bug Report]

 

@nikivi If you've been messing with your metadata and it's gone from working to not working, without any changes in Alfred, there is unlikely to be a bug in Alfred.

 

For due-diligence, I have taken the time to create a workflow to reproduce the bug you've reported, and everything is working as expected in macOS 11.0.1. Contacts are indeed parsed correctly.

Link to post

Okay I might be the unluckiest person or macOS hates me as I always get weird file system issues but indeed the file types of those files are not markdown but `dyn.ah62d4rv4ge8043a` as the metadata viewer showed:

 

image.thumb.png.8a6afb0b658ee82a546d648e1368c9b3.png

 

Might be something to look into though as when I did drop this file into here:

 

image.thumb.png.c7239fb127773b9d8330f02eb592c792.png

 

The `dyn..` stuff wasn't added. I'd consider that a bug as the metadata viewer did recognize the file type as `dyn..`.

 

This doesn't solve the contacts search issue though. Not sure what even went wrong there. File type seems ok:

 

image.thumb.png.326980ee12189276667cd0908df2ccc1.png

 

Permissions are granted:

 

image.png.ca6d651a48a986b9496151e7091a5bac.png
😐

Edited by nikivi
Link to post

Only one contact is being formatted correctly. Perhaps because I inspected it?

 

1681829074_CleanShot2020-11-30at15_42.01@2x.thumb.png.0930b89ad0d9503ffd1e791c5bc8af97.png

Also despite showing system files, not all contacts are being found again. Previously that option fixed my issue of Alfred not returning all contacts.

 

 image.png.deb63562c0632d6ef4deb7802defce80.png

 

 

Link to post
Just now, Andrew said:

What would you consider a bug?

 

This line I had to add manually by inspecting file with the Viewer then copying it from it from there.

1388921942_CleanShot2020-11-30at15_44.10@2x.png.dcd91c3f5ef4d45c6746eb9b069b44c2.png

 

I'd expect Alfred to fill in this line for me when I dropped `karabiner.md` file into this table view but nothing happened for me. That's why I assumed the file type was either `com.unknown.md` or `net.daring` but it was neither.

Link to post

I see, thank you @Andrew

 

Going to drop the only thing that worked for me so far, maybe it might give an idea of what's going on. Every time I drop a contact from here (where all contact metadata is kept):

 

image.thumb.png.6036de9a99df1480fac52972207dfafa.png

 

Into the Alfred Meta Viewer to inspect the contact. After that the contact starts to be found again. Example, not found:

 

image.thumb.png.cdc5eae761174eed98ce2dc37785e257.png

 

After inspecting contact with Alfred Metadata Tool and waiting ~ 5 seconds, the contact will be found and indexed correctly:

 

image.thumb.png.5c0f3a91f7120d4577d1d5634ff4dfa0.png

 

Makes me thing this is some permission thing between Alfred and the contacts themselves and somehow Metadata Viewer lets Alfred access the files correctly. Not sure.

 

Link to post

I tried to select all contacts (I have 856) and drop them all at once into the Metadata Tool but it unsurprisingly only opens one contact so it didn't work. Don't want to go through the process of doing the above for each one of the 856 contacts so any solution to this would be very welcome.

Link to post
  • Andrew changed the title to Issue with my contact metadata

Would it be possible to open source Alfred Metadata Tool? I am very curious to know what actually causes the act of inspecting a contact to be indexed properly by Alfred. So I can perhaps write a script to run it on all the 800+ contacts so all are indexed. I know this is a hacky approach but I don't have time to reinstall macOS from scratch (will do it when I get M2 mac machine).

 

If it's not possible, I guess I can live with it until then. Thanks.

Link to post

@nikivi the metadata tool is no longer used, it was superseded by the built-in file troubleshooting within Alfred's help preferences.

 

The metadata tool itself has no intrinsic link to Alfred, it's a completely independent app, and I suspect just the act of opening the file is causing macOS to update the last used metadata flag, which is fixing the single metadata record in your broken index.

 

You might find that creating a script to touch, open, or mdls each of those files will have exactly the same effect.

Link to post

I tried both open & mdls:

image.thumb.png.98473b84d9ca647a21fac34c68c9f151.png

 

And it didn't work. Alfred troubleshooting thing always works all the time. Not sure what you mean with touch command, I guess `cat` contact content to clipboard. Then create a new .abcdp file with the clipped content. I have a feeling that maybe it's Alfred checking whether the contact is in default search scope may do something too. 

 

image.thumb.png.a179ef5435a629a7fca989291504db23.png

 

Thanks for the help @Andrew. Just wanted to note this in case someone else has similar issues and finds this thread as those solutions didn't work for me.

 

 

Link to post
  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...