Jump to content

[Solved] Need to recover preferences


Recommended Posts

I cannot say what led up to this but it seems like it was some Alfred update. All my snippets and preferences are either missing or reset.

Furthermore, is there any place where the snippets might be saved so that I can recover them - same goes for other Alfred features that I have created and modified over the years.

 

There has been no warning that I was going to lose everything...so what happened?

Edited by Vero
Title edited to avoid being misleading
Link to post

@agilefalcon Welcome to the forum :) 

 

Could you provide more details so I can help you further?

  • Which version of Alfred are you using?
  • Which version of macOS are you using? Did you recently update to Big Sur?
  • Do you sync your Alfred preferences, and if so, which service have you been using?
  • Do you use Time Machine to back up your Mac?
  • Is this on a new Mac, or on a Mac where you've had everything installed for a while?

Alfred updates don't modify the preferences, so your preferences wouldn't have disappeared because of an Alfred update. 

 

However, if you're syncing your preferences and your Alfred.alfredpreferences file has been moved (e.g. by moving or renaming your Dropbox folder, by using iCloud to sync with Optimised Storage enabled), the preferences may have been pulled from under Alfred's feet.

 

If you let me know which service you use, I'll help you ensure that this doesn't happen again and that your settings are correct.

 

Provided you can locate a backup, it'll be easy to reinstate your preferences :)

 

Cheers,
Vero

Link to post

Sure can:

 

4.2.1 [1187]

10.13.6 High Sierra - I cannot update further due to age of iMac

I don't know anything about "sync" of Alfred preferences. I don't think I've ever seen that.

I use Time Machine.

This Mac has consistently run perfectly for 10 years. 

 

In addition, I purchased PowerPack and it was also missing. I re-added my PowerPack license. No idea why that disappeared.

 

Chris.

 

Edited by agilefalcon
Link to post

@agilefalcon If you've never synced your preferences, and use Time Machine, it should be very straightforward :) 

 

First pop Time Machine open, and go to the following location in your user directory:

 

~/Library/Application Support/Alfredl/

 

Within this folder, you'll find the Alfred.alfredpreferences file. Quit Alfred and restore this file.

 

When you relaunch Alfred, you may need to re-enter your Powerpack license details (drop us an email if you need help finding your Powerpack license details - though it sounds like you've got that in hand) and your preferences will be reinstated.

 

With regards to your Powerpack being disabled, did you use an App Cleaner / uninstaller / app zapper or any other app that claims to clear caches and make your Mac faster? These apps can be overzealous and remove files that are essential. If that's the case, please make sure that you don't allow these to touch Alfred's files, as it could have been the source of the issue.

 

Let me know how you get on :) 

Link to post

Okay, I did that and picked a year ago. When I restored it "recreated folders" because the path was different. I used the path you mentioned and found the preferences file there so I don't know what would have been different. I never changed anything. I looked at Time Machine path to the file and my current Alfred 4 path and they appear to be the same to me. As it turns out - it restored to an Alfred 3 directory. I then copied the preferences into the Alfred directory (as it turns out this is Alfred 4).

 

Missing snippets and workflows are back!

 

 I can use a key combination to pull up a pop up that then lists the collections and snippets in a dialog that lists the collections and snippets in the same column which is quite confusing. Shouldn't "Collections" and "Snippets" be something different instead of being listed together as peers? One is subordinate to the other, right? I generally don't use that but think I will going forward; I just think it makes this dialog messy to have both the collection and snippet in the same list together.

 

Also duplicative: A checkbox to "Automatically expand snippets by keyword" then when you Edit a snippet you get yet another checkbox for "Auto expansion allowed." How do these work together? 

 

The Collections now have to have a "Affix" and "Suffix" Why is that necessary? I used to just type "!" and then the keyword such as "!textplaceholder"

I found that I don't have to use the "Suffix" and hope that doesn't break something. Using a suffix is redundant to the keyword within the snippet, isn't it? Again this is duplication.... 

 

Incidentally, I have used an "app cleaner" before though not on Alfred... As you noted, perhaps it cleaned away something unintended. 

 

Otherwise it is working fundamentally now.

 

Thanks for the help.

 

Chris

 

 

 

 

 

Link to post
13 hours ago, agilefalcon said:

A checkbox to "Automatically expand snippets by keyword" then when you Edit a snippet you get yet another checkbox for "Auto expansion allowed." How do these work together? 

 

"Automatically expand snippets" in the top right is the global feature switch-on/switch-off, while "Auto expansion allowed" is on an individual basis. You may want to use the expansion feature, but not for all. I have entire collections of snippets saved which I don't intend to learn the auto-expansion keyword for, and just refer to via the Snippets Viewer.

 

13 hours ago, agilefalcon said:

The Collections now have to have a "Affix" and "Suffix" Why is that necessary?

 

Prefixes and suffixes are completely optional:

https://www.alfredapp.com/help/features/snippets/collections/#affix

 

You can choose a prefix for an entire collection, or set them on an individual basis.

 

I'll move this thread to Discussion & Help as this was not a bug.

 

Cheers,
Vero

 

Link to post
  • Vero changed the title to [Solved] Need to recover preferences

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...