Jump to content

Alfred 4.2.1 hang on launch related to Contacts access, Big Sur 11.0.1 (20B29)


Recommended Posts

@emmabaker Could you please drop us an email to info@ with the following information?

  • Your Diagnostics file, which you can get by typing "?diagnostics" in Alfred
  • Launch Activity Monitor, then launch Alfred and select it in the list of Processes. Click the Cog in the top of Activity Monitor and choose "Sample Process". Include this output into your email too
  • Let me know whether you sync your preferences, and if so, where you sync them to


As this is a very unusual issue, the more information you're able to provide, the easier we'll be able to help you out :) 



Link to comment
Share on other sites

@emmabaker as you likely can't type ?diagnostics into Alfred, you may be able to launch the preferences directly by right clicking on /Applications/Alfred 4.app and selecting "Show Package Contents", then navigate to Contents > Preferences and double click the Alfred Preferences app.


The diagnostics button can be found in the Help section of the preferences.

Link to comment
Share on other sites

  • Andrew changed the title to Alfred 4.2.1 hang on launch related to Contacts access, Big Sur 11.0.1 (20B29)
  • 2 weeks later...

I just had the same problem show up with Alfred 4.3, which failed to respond after a restart of the Mac mini M1. I fixed it the same way as suggested at the top of this thread. Somehow, System Preferences had reverted to allowing Alfred to access my contacts. When I disabled this, Alfred launched and now works OK.

Link to comment
Share on other sites

Saw this previously when I updated to Big Sur. Went away after deleting contacts files.
Just had same issue reappear now, after upgrading Alfred to 4.3 [1205]. It may or may not be related to the upgrade as I also did other things before I noticed Alfred + Spotlight + Contacts was broken.

This is what worked for me, with a restart immediately after deleting the Contacts files:





1. Open the AddressBook folder that is in the Application Support sub-folder of your user Library.

The easiest way to get there is to use Go To Folder in Finder (Go menu).

Copy and paste this path into the path field and click Go.

~/Library/Application Support/AddressBook

2. In that folder you will find three files,

  • addressbook-v22.abcddb
  • addressbook-v22.abcddb-wal
  • addressbook-v22.abcddb-shm

Move all of these files to the trash.



Edited by timoxley
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...