Jump to content

Alfred hangs on snippet expansion - M1 Big Sur


ngocphamm
 Share

Recommended Posts

Whenever I try a keyword that should have been expanded into the whole text, defined in Snippets section, Alfred hangs and I have to kill it via Activity Monitor, and start it again.
 
* Alfred version: 4.3.1 1214
* macOS version: 11.1, on a M1 mac mini
 
The same version of Alfred works fine on another machine of mine running Catalina 10.15.7 (Intel).
 
Please let me know if I can provide any more information.
 
Thank you!
 
Best,
Ngoc
Edited by ngocphamm
Link to comment
Share on other sites

@ngocphamm Very odd issue, and I don't believe we've heard of this behaviour before.

 

A few further questions:

  • Does this happen every time? Have you restarted your Mac since this happened?
  • Are you expanding your snippet in a specific app? If you expand in TextEdit (a basic, native app), what happens?
  • At what stage does Alfred seem to hang? You type your snippet keyword, and does it disappear? Does the snippet content appear?
  • What does your snippet contain? Is it a simple snippet, or a workflow?

Next time this occurs, please open Activity Monitor, select Alfred and choose "Sample Process" and paste the output here. That will allow us to see what's happening at that moment in Alfred.

 

Cheers,
Vero

Link to comment
Share on other sites

@Vero Thanks for answering, Vero!

 

I just tried and it doesn't happen now... I will try to "Sample Process" next time this happens, then.

 

* It did happen every single time when I reported this, yesterday. I could have sworn it only happened sometimes a while ago (same machine). I have not restarted my Mac in 27 days, but I think this had happened before that 27 days. Right now I'm not in a good place to retart so maybe I can try that later.

* I first noticed it when I tried to expand in a web form, using Firefox, but I tried with TextEdit also, and it happens there too.

* I type the keyword, and it does not disappear. The content does not appear either.

* The snippet is super simple. Just my email addres. I have a short keyword for it as I have to fill out my email pretty often.

Link to comment
Share on other sites

 Share

×
×
  • Create New...