Jump to content

snippet not working if there are character before the keyword


Recommended Posts

Environment

I am using macOS big sur, 11.1 (20C69) and also the newest version Alfred 4.3.1.

Problem

snippet doesn't expand if there are characters before the keyword.

For example:

The snippets I using are \ue --> ü, \oe --> ö, etc to write German words.

if I write \ue only, it will expand correctly, but when I write f\uer, it won't expand, and if there is a whitespace before the keyword \ue, it works. Others snippets also.

Troubleshooting

I have read the page https://www.alfredapp.com/help/troubleshooting/snippets/ and follow it to solve my problem.

the only effect is to make the snippet working but still having the problem above. In fact, the snippets don't work completely before I did those things in the article.

And also, Strangely, it doesn't work again for a while, when I writing this post.

What I have done.

  1. Make sure that I have activated expansion in Alfred's preferences , set the snippets to auto expand and used the correct keyword
  2. Check cmd+v is still the way to paste.
  3. Check Accessibility for Alfred
  4. Kill Alfred completely and then remove Accessibility permission of Alfred and add again
  5. Test in several different app and make sure they are not using secure input to prevent Alfred to auto expand
  6. Change the option, simulated key event speed, I have tried all choices.
  7. check Others app which may be conflict with app. I don't use other apps which are about the clipboard and also text expansion.

 

Link to post
Share on other sites

@Xin Welcome to the forum :)

 

For what you have in mind, you need to enable mid-string expansion. 

 

In Features > Snippets > Auto-expansion Options > Options - you'll see a checkbox to Expand snippets mid-string. Check that box and you'll be good to go :)

 

Cheers,
Vero

Link to post
Share on other sites

@VeroThanks for your help. The main problem is solved perfectly.

Sorry, it's hard for me to imagine to why to distinguish when text expansion needs taking effect depending on whether the keywords are in mid-string or not. Hence I don't consider that and don't notice that option.

But the another problem I mentioned in the post that the snippets isn't working occasionally is still hanging.

I guess it's better to create a new post. it's really strange for me.And I think it maybe a real bug.

here is new post.

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...