Jump to content

Snippets being blocked anywhere if there is an app preventing it.(Maybe the description not accelerate)


Recommended Posts

 

Environment

I am using macOS big sur, 11.1 (20C69) and also the newest version Alfred 4.3.1[1214].

Problem

snippets not working occasionally. Yes, occasionally, I have seen some strange behaviors. I will explain it in detail.

Description

At first, I google it due to the unavailability of snippets, and follow the way I found in internet to solve my problem.

the details are in this post,

But I now find those aren't the real reason that making snippets unavailable. At beginning, I also think it may be caused by the Accessibility permission or the interfering of other apps using accessibility permission.

Today I notice this alert like the image below.Although I don't test snippets in safari so I ignore it before, it's not working in all apps.

image.thumb.png.ca2d9194eb0fe1faf67d01eabe66759b.png 

And then I decide to try to kill the safari completely, and others following apps displayed by Alfred which are blocking text expansion by locking secure entry.

Those apps contains, as I have observed, safari, telegram ,some process,(Alfred display its process ID not App name).But strangely, when I try to use the order ,kill {process ID},what I got is only there is no such process in shell.

After I kill all the apps display above, snippets function normally in all the place again.

Unfortunately, after a while when I launch those apps, snippets is not working again and Alfred display that information again. 

I need to emphasize that the snippets works for a short time not stopping working as I launch these apps.

How to reproduce

I don't know the exactly steps to reproduce the strange bug.

but it's actually reproduced in my computer again and again.

My thoughts

I guess the real reason that make snippets unavailable is the incorrect  implementation of the api of secure input. But I don't know clearly the details of the fundamental implementation of OS X.

Link to post
Share on other sites

New discovery:

I am wrong completely. When the Alfred display some process is blocking text expansion, although I don't succeed to kill such process, I try to kill some other apps to experiment. 

Outcome is that when I kill Bitwarden, a password manager app, whose official website is https://bitwarden.com, the alert in Alfred disappears and luckily the snippets work again.

so I guess the process which is even unable to be killed using the order "kill" is launched by Bitwarden and owing to its purpose to improve security the app make such process unaccessible, which is really unbelievable for me, first time to know.

But the problem is that I only put the app bitwarden at background. I am pretty confused.

And the behavior is really strange. If I relaunch bitwarden, I can use snippets in the app and also any other place I like. But for a while after I locked it and leave it at background, the process makes snippets unavailable unless you close the app again.

How to reproduce

install bitwarden......lol 

Conclusion:

There is a conflict between the app Bitwarden and the function snippets of Alfred. I don't know why this happened and hope some one can help me. I will also report this bug to bitwarden.  

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...