Jump to content

Alfred starts up frozen and unresponsive [macOS Contacts issue]


Recommended Posts

Hi,

 

Been using Alfred for a while and since yesterday I can't seem to start it. 

Whenever I do it get's frozen.

 

I think it started following a recent update but can't say for sure.

 

I've taken a sample from "Activity Monitor" incase it helps. 

(https://drive.google.com/file/d/1XlXe8eM5k6dmn6FCUGzDoO2rQDdG51qF/view?usp=sharing)

 

For more context - I'm on Big Sur 11.2.1

 

UPDATE - It eventually unfroze but it took a few good minutes

Edited by Ben100
Link to post

@Ben100 Looks like you might be experiencing the same issue as the user in this thread, where macOS is being slow at returning contacts and holding up Alfred.

 

 

As Andrew said, we'll be looking at moving the contacts access check off the main thread, but for now, if you open the macOS Permissions to Security & Privacy and untick Alfred from having access to contacts, this should prevent macOS from holding up Alfred.

 

Also, perhaps try restarting your Mac in case the macOS Contacts service has failed, as I believe most users only encountered that issue once with everything working smoothly after a restart.

 

Cheers,
Vero

Link to post
  • Andrew changed the title to Alfred starts up frozen and unresponsive [macOS Contacts issue]

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...