Jump to content

Alfred not finding files since Big Sur update


Recommended Posts

Since I updated to Big Sur, Alfred is not finding some files and folders. I updated from Alfred 3 to 4 to try to fix the issue, but it persisted. I've rebuilt spotlight data, and spotlight finds the files and folders just fine. mdfind locates them as well, without issue. I've gone through Alfred's "file search troubleshooting", and it gives me a lot of green checks and "Troubleshooting passed".

 

The output from one of these troubleshooting runs is copied below: note that Alfred very much does *not* find this file, even if I type in its full name, despite its "all is well" output. Here's something else weird: before I rebuilt the macOS metadata, Alfred would find this file, but not the folder containing it. After the rebuild, on the other hand, Alfred finds neither the file nor the folder containing it. (Spotlight and mdfind find both the file and its containing folder without issue, both before and after the rebuild.)

 

I've searched and found a bunch of people with similar issues, but the steps I've tried seem to have worked for most of them. So I'm out of ideas here; is there something else I can do to get Alfred working again? Or does it just not really work on Big Sur?

 

Copied troubleshooting output below:

Quote

 

Starting Diagnostics...

File: 'combinators-and-classes.pdf'
Path: '/Users/drip0001/Dropbox/Pdf library/Scott, Dana'

-----------------------------------------------------------

Check file cache database...

File cache integrity is ok

-----------------------------------------------------------

Check if file is readable...

Alfred has permissions to read this file.

-----------------------------------------------------------

Check if volume '/' is indexed by macOS...

Indexing is enabled on this drive

-----------------------------------------------------------

Check direct file metadata...

Direct metadata available

Display Name: combinators-and-classes.pdf
 Other Names:
Content Type: com.adobe.pdf
   Last Used: 2021-03-10 00:54:44 +0000

-----------------------------------------------------------

Check mdls file metadata...

Metadata contains required items

_kMDItemDisplayNameWithExtensions      = "combinators-and-classes.pdf"
kMDItemContentCreationDate             = 2020-06-09 06:50:43 +0000
kMDItemContentCreationDate_Ranking     = 2020-06-09 00:00:00 +0000
kMDItemContentModificationDate         = 2020-06-09 06:50:43 +0000
kMDItemContentModificationDate_Ranking = 2020-06-09 00:00:00 +0000
kMDItemContentType                     = "com.adobe.pdf"
kMDItemContentTypeTree                 = (
    "com.adobe.pdf",
    "public.data",
    "public.item",
    "public.composite-content",
    "public.content"
)
kMDItemCreator                         = "0100.TIF"
kMDItemDateAdded                       = 2021-03-02 22:38:30 +0000
kMDItemDateAdded_Ranking               = 2021-03-02 00:00:00 +0000
kMDItemDisplayName                     = "combinators-and-classes.pdf"
kMDItemDocumentIdentifier              = 0
kMDItemEncodingApplications            = (
    "PageGenie PDFGenerator"
)
kMDItemFSContentChangeDate             = 2020-06-09 06:50:43 +0000
kMDItemFSCreationDate                  = 2020-06-09 06:50:43 +0000
kMDItemFSCreatorCode                   = ""
kMDItemFSFinderFlags                   = 0
kMDItemFSHasCustomIcon                 = 0
kMDItemFSInvisible                     = 0
kMDItemFSIsExtensionHidden             = 0
kMDItemFSIsStationery                  = 0
kMDItemFSLabel                         = 0
kMDItemFSName                          = "combinators-and-classes.pdf"
kMDItemFSNodeCount                     = 930688
kMDItemFSOwnerGroupID                  = 907548567
kMDItemFSOwnerUserID                   = 1256056683
kMDItemFSSize                          = 930688
kMDItemFSTypeCode                      = ""
kMDItemInterestingDate_Ranking         = 2021-03-10 00:00:00 +0000
kMDItemKind                            = "PDF document"
kMDItemLastUsedDate                    = 2021-03-10 00:54:44 +0000
kMDItemLastUsedDate_Ranking            = 2021-03-10 00:00:00 +0000
kMDItemLogicalSize                     = 930688
kMDItemNumberOfPages                   = 26
kMDItemPageHeight                      = 691.28
kMDItemPageWidth                       = 468
kMDItemPhysicalSize                    = 933888
kMDItemSecurityMethod                  = "None"
kMDItemTitle                           = "Combinators and classes"
kMDItemUseCount                        = 1
kMDItemUsedDates                       = (
    "2021-03-09 13:00:00 +0000"
)
kMDItemVersion                         = "1.3"

-----------------------------------------------------------

Check file is in search scope...

File exists within Alfred's default search scope

-----------------------------------------------------------

Troubleshooting passed

 

 

 

 

 

Edited by davewripley
Link to post

@davewripley Could you please provide your Diagnostics file, which you can get by typing "?diagnostics" into Alfred. You can then drop us an email to info@ with it. :)

 

What do you type into Alfred to search for this PDF? Provided you still have your Alfred settings to default, you'll need to prefix your search term with the spacebar (to broaden your search beyond the essential file types).

 

Also, I see your file is on Dropbox. Is Dropbox set to use its Smart Sync service? If so, it means that Dropbox will decide which files to keep on your Mac, and which to only store on the cloud. If this is enabled, it could be playing a part in some files appearing in results less reliably recently.

 

Cheers,
Vero

Link to post

Thanks very much! The computer in question is my office computer; I'll send along the diagnostics email next time I'm there, but that won't be until next week.

 

I know to put a space at the front, although I did also try without the space as part of trying to troubleshoot. No luck either way. I also have a workflow set to filter for pdfs, which also fails to locate this file. Similarly, I have a workflow set to filter to folders, and it doesn't find the immediately containing folder, nor does Alfred find that folder with or without a space at the front.

 

That is, with "p " as the keyword for the pdf filter and "f " as the filter for folders, none of the following suceed (I'm not typing the quotes into Alfred; I've just put them here to be clear about where there are and are not spaces):

"p combinators-and-classes.pdf"

" combinators-and-classes.pdf"

"combinators-and-classes.pdf"

"f Scott, Dana"

" Scott, Dana"

"Scott, Dana"

 

Both the pdf and folder workflows have worked for me without trouble for years; they're about as simple as workflows get---just a "file filter" linked to an "open file" action. They still work to open pdfs and folders that Alfred can find through its default behaviour.

 

I do not have Smart Sync set up on my Dropbox; everything is stored locally. Alfred does succeed at finding files (including pdfs and folders) in some other places in the Dropbox. However, it failed on every file and folder I checked within the folder "~/Dropbox/Pdf library". It occurs to me now that I don't think I checked whether Alfred can find "~/Dropbox/Pdf library" itself; I'll check that next time I'm at the computer.

 

I don't know of anything Alfred can't find that's outside the Dropbox. But basically all my files on the computer in question are in the Dropbox, so that's not a huge surprise in itself.

Link to post

@davewripley, I think we're having the same problem. In my case Alfred can see things stored in Dropbox that I've worked on recently, and some other random bits, but not most of the older stuff. If I search in the spotlight pop-up (the default cmd+space) I can find any file on the computer, even if Alfred can't.

 

I rebuild the metadata and things work fine for a little while (hours, maybe days), but then its "long-term memory" goes away.

 

Do you have houdahspot? It's another frontend for spotlight that gives some really detailed file search options. It also has the same problem as Alfred, where it can only find a small set of the files stored in Dropbox.

 

All that makes me think it's a spotlight/dropbox issue, but I haven't been able to figure out more than that.

Link to post

Hmm. Seems like it might be the same, but might be different; my issue doesn't seem to have to do with recency. It's just that some locations (including one folder with all my research pdfs in it!) don't seem to be getting searched. And rebuilding the metadata doesn't seem to help, even for a moment. So maybe you and I are having different issues?

 

I can say, now that I'm back in the office, that Alfred *does* find the folder "~/Dropbox/Pdf library". Moreover, it now, after being left alone for a week, even finds the folder "Scott, Dana" inside that folder. (I've made no changes of any sort on this computer; nor have I modified that folder in the dropbox, although I have made other changes in the dropbox. Spotlight reported that the metadata was already fully rebuilt before.) But Alfred still does not find very many folders inside "~/Dropbox/Pdf library", and it does not seem to find any pdfs inside any of these folders, whether or not it finds the folders themselves.

 

I hadn't tried Houdahspot before, but after installing the trial, I can confirm that it exhibits the very same gaps in coverage that Alfred does. Spotlight finds everything fine, and Alfred and Houdahspot both seem to succeed on some things and fail on others, matching perfectly as far as I can tell in what they succeed and fail on. That certainly does seem like relevant information!

 

Anyhow, I've sent the diagnostic email as requested; hopefully it helps! (But I also misspelled your name, Vero, in that email; I'm sorry!)

 

 

Link to post

 

7 hours ago, davewripley said:

hadn't tried Houdahspot before, but after installing the trial, I can confirm that it exhibits the very same gaps in coverage that Alfred does. Spotlight finds everything fine, and Alfred and Houdahspot both seem to succeed on some things and fail on others, matching perfectly as far as I can tell in what they succeed and fail on.

 

@davewripley This behaviour indicates that the macOS metadata is missing these folders or incorrectly indexing them. Spotlight may be showing results for now but it'll be using an internal cache, which will eventually expire and likely begin to show the same gaps you're seeing in Alfred and any other third-party apps that use the same underlying index.

 

I appreciate you say you've reindexed already, but please follow the steps below specifically (as it involves deleting a cache first and ensuring Terminal has suitable permissions).

  • First, please pop open System Preferences > Security & Privacy > Privacy > Full Disk Access and add Terminal
  • Once you've done this, go to Alfred's Advanced preferences, choose "Rebuild macOS Metadata"
  • Ensure that you check "Delete .Spotlight-V100 before reindex"
  • Follow the steps in Terminal, and keep a close eye for any error messages relating to your index. 

Please let me know if there are any errors. Otherwise, if it proceeds smoothly, you may need to wait up to an hour for the reindex to complete. Once this is done, type "reload" into Alfred to refresh the application cache (though I don't believe apps are affected in your case), then make your searches again and see if your results are more as expected.

 

Beyond that, you can try dragging your research PDFs folder to the Desktop and seeing if the contents are found at that point. If so, return your folder to Dropbox; This might nudge macOS further into correctly reindexing the contents of the folder. At the very least, it will confirm whether this issue only occurs when the contents are in Dropbox.

 

Let me know how you get on.

 

Cheers,
Vero

Link to post
On 3/15/2021 at 10:41 AM, dansherman said:

I rebuild the metadata and things work fine for a little while (hours, maybe days), but then its "long-term memory" goes away.

 

Alfred doesn't forget randomly, it's down to the macOS metadata index either providing or not providing file results.

 

Do you use any third-party tools that may be manipulating the index, such as Onyx or cleaner apps that may be removing caches or affecting the index?

Link to post

Thanks for the advice! I'll try these same steps for deleting metadata another time once I'm back at the computer in question on Wednesday; I'll also check what happens with changing the location of the folder in question. Hopefully one or the other of these works!

Link to post

I appreciate that you need to check, so I did go through this sequence of steps again. (The only difference is that I did not "reload" Alfred before; but I've done that now as well.) I've copied below the output I received in the Terminal window that opened, in case this helps. All looks fine to me there. Spotlight indicated that it has completed the reindexing from about half an hour later; it's now four hours later, so I feel confident it's done. Alfred's behaviour seems to be unchanged; I still cannot find in Alfred what I could not find before. I still find everything fine via Spotlight.

 

I also made a copy of the pdf folder on my desktop (before reindexing); nothing in that copy is being found by Alfred either. That copy too is searched by spotlight no problem. Since that's outside the dropbox, it doesn't seem like the dropbox was the issue. Because spotlight continues to work without issue, it certainly seems to me like macOS is indexing things fine, and that the information is not being picked up by Alfred for some reason. I'd definitely appreciate any help!

 

~ /Applications/Alfred\ 4.app/Contents/Frameworks/Alfred\ Framework.framework/Versions/A/Resources/reindexdel.sh ; exit;

***************************************************
*                                                 *
*    This script will reindex your metadata by    *
*      firstly deleting .Spotlight-V100 then      *
*   running the command 'sudo mdutil -E -i on /'  *
*                                                 *
*         Indexing can take up to an hour         *
*     and Alfred won't work during this time.     *
*                                                 *
*   You can see the progress of the reindexing    *
*      by performing a search in Spotlight.       *
*                                                 *
***************************************************

Close this window to cancel, or press any key to continue...

Attempting to delete .Spotlight-V100...

Password:

Requesting metadata reindex...

/:
	Indexing enabled. 

You can see the progress of the reindexing by performing a search in Spotlight

Press any key to finish...

logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.
Deleting expired sessions...none found.

[Process completed]

 

Link to post

@davewripley The fact that you're seeing the issue in Houdahspot as well indicates that it's an issue with your Mac's metadata, not with Alfred, so there are only so many suggestions I can make. You'll need to experiment and troubleshoot on your own Mac to narrow down whether there are files with non-standard characters that are causing metadata issues, work out whether it's specific files and/or folders. 

 

For example, what happens if you create a new folder on your Desktop and copy one or two folders from your PDF folder? Or if you create a file on your desktop and move it TO your PDF library folder where you can't find files? Are there specific files being found and others not? 

 

You will need to get a bit analytical with your sleuthing, but Big Sur has generally been extremely reliable and stable for a vast majority of users, so I'm sure you'll be able to get to the bottom of your issue.

 

Cheers,
Vero

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...