Jump to content

Recommended Posts

Hello!

 

Ever wanted to quickly convert currencies within your Alfred Window but all existing workflows lack this one or that one feature and the exotic currency you need for your next post-pandemic holiday trip is missing?

 

That’s why we have created the Ultimate Currency Converter – first just for ourselves, but it might also be helpful for you.

 

workflow--dark.png

 

Get it from here: Ultimate Currency Converter – GitHub Release Page

 

For usage information: just play around with the currency keyword or look at the README.

 

In case you have any bug findings, any suggestions or wishes, please don’t hesitate to post here or open a GitHub issue.

 

And if this workflow turns out to be helping you, consider to help us with our coffee bill :-) → paypal.me/n8g1

 

Best

 

 – Erik from Little Brighter

Edited by vitor
Toned down hyperbole in title
Link to comment

Welcome to the forums,
 

I have toned down the original title, as both it and the top of your post punch down on other Workflow developers who also worked hard on their converters. The Alfred forums aim to foster a respectful community where we try to support each other and have everyone’s Workflows be better.

 

The “best” workflows are subjective. The power of Alfred lies in everyone being able to decide on their own tradeoffs. By requiring users get an API key, your Workflow is already disqualified for plenty of people.

 

While it’s fine to ask for donations, that in conjunction with the rest of the post and title made it look like spam. We don’t know you yet and can’t even trust you’ll stick around and fix bugs in your work (almost no one makes a living on open-source donations, and none of those are making Workflows). Please get to know the community (and let us know you) before making definite claims.

Edited by vitor
Link to comment
  • vitor changed the title to Ultimate Currency Converter
  • 3 weeks later...

Hey,

 

don‘t worry. Go to the Environment Variables window in the screen that you are showing. It is the first button on the top right with the Greek letter chi in square brackets. 
 

In the window that opens, add your API key for the value of the Environment Variable “lb_freecurrencyconverter_api_key” in the right half of the window. 
 

Best

 

Erik

Link to comment
  • 1 year later...

Hi,

I obtained the API from https://free.currencyconverterapi.com/free-api-key

I entered the API into the appropriate "VALUE" field per your instructions above.

However, when I try to use the workflow, I get the following error message:

 

Error: invalid API key given in Alfred Preferences

 

I tried obtaining a different API using a different email address, but same problem.

 

The debugger shows the following

 

[08:41:41.015] Ultimate Currency Converter[Script Filter] Queuing argument ''

[08:41:41.697] Ultimate Currency Converter[Script Filter] Script with argv '(null)' finished

[08:41:41.700] Ultimate Currency Converter[Script Filter] {"items": [{"title":"Error: invalid API key given in Alfred Preferences","subtitle":"Hint: please edit Workflow Environment Variables in Alfred Preferences.","valid":false,"icon":{"path":"icon-error.png"},"arg":"--get-api-key"}]}

 

Workflow Version v1.12.2

PHP Version 8.1.4

Alfred Version 4.6.4

macOS Version 12.3.1

 

Please advise.

Link to comment

Hello mlondon,

 

I'm really sorry that you run into so many issues with UCC (rf. github)

 

You did not do anything wrong, I think. The free API seems to be down, please see here https://www.currencyconverterapi.com/server-status

This also happened once last year. Fingers crossed, they revert to operation soon. Hint, we are not connected to this API ... just using them

 

(I will close GitHub issue, as you seem to have successfully installed PHP).

 

Best

Link to comment
  • 3 months later...

Hello,

 

I'm trying to use this workflow on Alfred 5 and it's not working properly. Default currency from and to command and look-up, both works fine. But the "currency" command is always defaulting to web search.  When I start typing "currency" it shows the command as a result, but if I finish typing or just select the comnand, web search takes over and don't let me finish typing the number I wanna convert.

Link to comment

Hello @jojordani,

 

in order to dig a little deeper, could you be so kind and share some details of your setup? Which macOS Version, which Alfred version, what PHP are you using (bundled Apple version or homebrew manual installation (latter case: which version), what API are you using?

 

Please also share Alfred debug output, in Alfred 5 you can reach it by pressing CMD+D key, when you are viewing this workflow in Alfred preferences.

 

Thanks

Link to comment

Looking at the bug report I noticed that the problem was the api key. I tried using exchangeratesapi but it was not working, apparently. I created an account at getgeoapi and used their key and now it worked flawlessly. Thank your for your help, and for this amazing workflow.

 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...